Qualcomm Atheros AR9462 WiFi slow speed


I recently changed my internet provider. They changed the router and the WiFi network. Before that my WiFi connection speed worked fined but now I only have 0 - 1Mb speed. In my phone I have 100Mb.

I’ve tried adding ipv6 disable & pcie_aspm=off via grub boot parameters following this solution but it only worked ONCE. When I turned off and on my laptop it had the problem again and the solution didn’t work.

This is the inxi -Nazy result:

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: AzureWave 
  driver: ath9k v: kernel port: 4000 bus-ID: 03:00.0 chip-ID: 168c:0034 
  class-ID: 0280

And this is my system info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.2-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-5200U CPU @ 2.20GHz
Memory: 7,7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 5500, NVIDIA GeForce GTX 950M

Any help?

Obviously not a Manjaro issue but something with the router’s access point setup.

Even when the solution I tried worked at least once?

When your wifi connection goes bad after a ISP change - why is it you think it is the operating system?

Not sure. Reading other solutions related to the OS I thought maybe they could also work for me. I’ll contact the internet provider technician to see what he can do. I’ll post any info or solution here.

The technician rebooted the connection and the configuration. We tried with an ethernet cable and it worked as expected but when I connect via WiFi the speed drops instantly. He told me the problem may be caused by the Wireless Network Adapter. :frowning:

Hi @bejuco ,
I wonder whether you could run the following command in order to see the wifi connection dropped.

journalctl -f | grep ath9x

The output will display the errors, if any, on the wireless connection.

Hope it help, regards


journalctl -f | grep ath9x

This runs but doesn’t print anything.

Hi @bejuco,
Maybe I am wrong, could you please execute this command on the terminal:

```journalctl -xe | grep ath9x``



Again, it runs but it does not print anything D:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.