QT6 breaks globalmenu in strawberry and qbittorrent

In xorg there is no problem, the problem is in wayland :frowning:
any workaround?
In addition I lost the systray icon on uget(not qt relationed)… I dont remember if was working at some point…
And close buttom don’t close to tray strawberry( I remember it was working a few time ago in wayland so I suppose its a regression from QT6 too)
Thanks in advance mates!

I just noticed the same with strawberry on wayland. I had to remove qt6ct to be able to start strawberry again and yes, no systray icon (and because of that no close to systray too - it’s all greyed out in settings). it worked with qt6 until the last update, i think

PS: i just found this one, which seems to be the root of our problems: https://www.reddit.com/r/kde/comments/ryg1w9/qbittorrent_breeze_and_qt6/

PPS: strawberry-qt5 from aur brings back a fully working player with systray for now.

I think community versions should be compilled with QT5 and not QT6 while KFE are QT6 too… since it gives less problems, working systray, working globalmenu… manjaro is oriented to normal people so it has to have in ming all this things… I have been capable to change to qt 5 version from aur and fix “my” problem but the newbie people are going to leave it and get upset and "quiet " from Linux desktops

some way to fill a bug or to ask for compile some apps with QT5?

I just found an even easier way to handle: just rename (or delete) the folder “qt6ct” within your “.config” folder and qt6 is working again.

i have no folder called qt6ct on my system ._.

it should be hidden within your home folder ~/.config/qt6ct
What happens if you enter the command qt6ct in terminal?
Else you maybe need to install it first? :man_shrugging:
it’s the settings app for qt6

I had to open the qt6ct app and after removing that folder that was not created before, nothing fix my problem, are you sure that Qbittorrent and strawberry from community repos have working globalmenu and close to tray(only strawberry) in wayland sessions?

When I tried to start qt6ct it crashed immediately but it helped to delete the folder and start the settings app again.(so the folder gets recreated new) After that, strawberry is running with QT6 / Wayland / Gnome.
I think it’s something with the “older” qt6 settings, maybe some older style settings are not supported anymore.
But I only can write for strawberry, never used qbittorrent.

PS: I just saw you are on testing, I’m on stable, so this could also be a reason.

you are speaking about other thing! hahaha, nevermind, nothing. I have no problems with errors on launch, is about global menu feature on plasma desktop and tray icon that is used in a weird way

Okey, I have found a little time ago without problems 2 workarounds:
1 less problems, simply forcing strawberry and qbittorrent to run on xwayland inside wayland so you get globalmenu without problems on both
2 using qt5 version from aur that imply compilation resources… or using another repository that implies you ll get errors for libs that are different from arch ssome times.
Im using 1 right now after being a while on the first

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.