Qt5 apps don't display properly

After a fresh install of Manjaro on a new machine, I’m experiencing display issues related to Qt5 apps.

Fonts seem oddly condensed and icons are displayed in the wrong color. Hard to explain in words, thus I made a couple of screenshots.

Broken (newly installed machine):
screenshot removed

Correct (other machine with older installation):
screenshot removed

I haven’t changed any theme-related KDE settings other than switching to dark mode. How can I fix this?

You probably need to set the icons to breeze-dark (or however they are called.)

That did at least fix the icons for Skanlite, but other apps like KeePass still look way off (font + colors). I tried all theme-related settings I could find to no avail.

screenshot removed

screenshot removed

Maybe it’s also needed in qt5ct and/or qt6ct.

However, someone with more experience with KDE and Plasma may have better ideas.

Also tried a new user account / profile. No luck either, same results. The default configuration seems to be buggy somehow.

Plasma users should not install qt5ct or qt6ct. Those are for configuring the qt look & feel in desktop environments based upon another widget toolkit than qt, and installing them in Plasma will mess up Plasma’s own configuration settings.


I think your broken KeePassXC actually looks much better with the datker background. However, the Windows version does also have the lighter grey.

Just my 2 cents… spend it wisely.

It certainly looks interesting, but those barely visible black icons for the “Unlock” and “Close” buttons are a giveaway that this is not the intended look.

Speaking of icons, I just noticed that the “Open Database” icons near the top left corner is different. But both screenshots are from fully-updated Manjaro installations and show the same version of the app.

That might depend on the icon theme selected.

Close all you Qt5 apps,
then install plasma5-integration and breeze5,
and re-apply your global Breeze theme inside Plasma 6 settings application.

KeepassXC icons are half broken on Linux/KDE, and the dev has no intention to fix it.


That fixed it! Love you, my man! Actually, only plasma5-integration was missing, breeze5 was already installed.

I feel like that package should have been installed by default or pulled in as a dependency when Qt5/Plasma5 apps are installed.

Bummer. Thanks for the info. BUT: is this really a KeePass issue? I’m only experiencing this on ONE of my Manjaro machines, as the screenshots show.

Nicolas Fella (KDE Software Platform Engineer) already gave him a hint to what is wrong.

I see, did not read the whole thing. But the issue is still open and has been added to the 2.8 milestone, so this likely will get fixed. They are pretty reliable, contributed to the project myself a couple of times.

LibreOffice seems to have similar issues:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.