Qt5-accessibility.sh: QT accessibility is forced ON by default?


Mods, please move to the KDE category, I didn’t think of it when finished writing.

/etc/profile.d/qt5-accessibility.sh automatically sets the environment variable: export QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1.

I don’t need it, what is the proper way to override it? I am afraid that if I just edit the file, it would come back as part of some updated package.

This topic was discussed in Debian in 2017: official mailing list or Google Groups link to the same thread. Another comment.

According to [upstream] setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1 has a
huge negative performace impact on Qt, so it should not be enabled by
default. And, if I understand correctly, this is the current behavior.

TLDR: The performance impact comes from the fact of sending the necessary events even though not needed. So it is especially important to not have this forced on mobile when not necessary. Though I don’t know if QT improved this situation on their end?

I have not found any mentions to this on Arch/Manjaro forums.

$ pacman -Qo qt5-accessibility.sh
/etc/profile.d/qt5-accessibility.sh is owned by manjaro-kde-settings 20230404-1

Link to commit of manjaro-kde-settings. No explanation.

PS: Funny, there isn’t even a forum tag for “accessibility” or “a11y”

To add for what its worth…

A current scrape of repos shows the file comes from any one of these packages

community/beelink-kde-settings 20221214-1
community/manjaro-kde-settings 20230404-1
community/manjaro-kde-tx-settings 20221214-1
community/minisforum-kde-settings 20221214-1
community/slimbook-titan-settings 20221214-1

My understanding was that there was virtually no reason for running systems to continue to have manjaro-*-settings installed. It is not here, and I do not have the file.