Qt Creator will not work on Manjaro. I'm desperate

FYI I just tried it with Ubuntu packages and it’s doing the same thing.

On the Qt Bug Report I reported, they told me to try adding Qt manually. I am getting an error on all qmake binaries I try to add. Here is the error, I thought it may help:

The qmake executable /home/user/Qt/6.6.2/gcc_64/bin/qmake could not be added: “/home/user/Qt/6.6.2/gcc_64/bin/qmake” produced no output: /home/user/Qt/6.6.2/gcc_64/bin/qmake: symbol lookup error: /home/user/Qt/6.6.2/gcc_64/bin/qmake: undefined symbol: _ZN9QtPrivate25QMetaTypeInterfaceWrapperI7QStringE8metaTypeE, version Qt_6

And then it says qmake is not readable. I have no idea what to make of this.

Also I just got this error in a rogue X11 window that seemed to have come from the Ubuntu packaged Qt Creator:

Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimalegl, xcb, wayland-egl, linuxfb, vkkhrdisplay, vnc, wayland, offscreen, minimal, eglfs.

And… apparently this is a rabbit hole that never ends. I searched on this error and found an old forum post that indicated to run qtcreator with QT_DEBUG_PLUGINS=1. When I did I got a dialog with the following:

The following plugins have errors and cannot be loaded:

Plugin initialization failed: Cannot create OpenGL context.

Though when I checked my vid card support it was at OpenGL 4.3

I don’t know what you’ve done but that should not be installed in your home directory. Remove it. qmake and qmake6 are installed with qt5-base and qt6-base packages.

$ which qmake
$ pacman -Qo /usr/bin/qmake
/usr/bin/qmake is owned by qt5-base 5.15.12+kde+r151-1

$ which qmake6
$ pacman -Qo /usr/bin/qmake6
/usr/bin/qmake6 is owned by qt6-base 6.6.2-4

Something is wrong there too because I’m pretty sure Radeon RX 550 should support OpenGL 4.6. Post output of glxinfo -B.

And now this has evolved from an xy problem into an xyz problem - do yourself a favor uninstall everthing - clean up your local configuration - that is in $HOME everything related to your Qt adventure.

There is absolutely nothing wrong with QtCreator qmake, cmake packages or their dependencies.

You have royally screwed your settings - I suggest you create a new user with nothing installed locally (that is using the unified installer).

Then use the pacman package manager to install the qtcreator package.

1 Like

I have reinstalled entire operating systems many times. In fact, I just reinstalled Ubuntu now and no change. I did one fresh install of Manjaro and two of ubuntu and tried installing qt creator immediately each time. I have tried both the installer and package manager on fresh installs.

Yeah I said 4.3 instead of 4.6. Sorry to confuse.

I installed under home because that’s the default for the Qt installer. When I install through the snap store it goes in /snap.

And there is no package qt6-base in ubuntu. qt6-core was installed when I was trying in Manjaro. I have packages qt-framework and qt-framework-6-6-core22 installed under Ubuntu which goes under /snap. I have tried adding qmake from all of them.

We cannot provide assistance for ubuntu.

On Manjaro we encourage you to use the packaged software, especially as whatever manual methods you have attempted are failing.

This is Manjaro support. If you need help installing on Ubuntu then go to Ubuntu support forums.

@linux-aarhus is right, all this stuff you’ve installed that you shouldn’t have has by now completely screwed up your settings. Create a new user and install the packages qtcreator-devel, qt6-doc, and qt6-examples only. NOTHING ELSE. If that doesn’t work then come back and request help from there, and include your full system information from inxi -Fazy.

1 Like

Thank you, the only point I was trying to get across with Ubuntu was that it wasn’t just a Manjaro problem. My preference is Manjaro so that’s why I posted here. I will stick to Manjaro and I will try your recommendations.

Thanks again.

Hi there. I did what you said, except I upgraded first and I get the same result.

If you want me to try it without upgrading first I can, but I couldn’t figure out how to populate the repositories without upgrading and so therefore it couldn’t find any packages. Also I don’t really see the point if I can’t upgrade.

Here is my inxi -Fazy output. Also note that I tried Wayland first and then I logged back in with X11 and tried it again.

  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=568dad8b-0d81-4622-82a0-12aba9f32559 rw quiet splash
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 3020 v: 00
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Dell model: 040DDP v: A01 serial: <superuser required> part-nu: 0612
    uuid: <superuser required> BIOS: Dell v: A20 date: 05/27/2019
  Info: model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1575 high: 3900 min/max: 800/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3900 2: 800 3: 3900
    4: 800 5: 800 6: 800 7: 800 8: 800 bogomips: 54294
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
    driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
    built: 2016-20 pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 3
    speed: 8 GT/s ports: active: HDMI-A-1 empty: DVI-D-1 bus-ID: 01:00.0
    chip-ID: 1002:699f class-ID: 0300 temp: 40.0 C
  Display: wayland server: X.org v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 550 / 550 Series
    (radeonsi polaris12 LLVM 16.0.6 DRM 3.54 6.6.19-1-MANJARO)
    device-ID: 1002:699f memory: 3.91 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: N/A device: 0 type: discrete-gpu name: AMD
    Radeon RX 550 / 550 Series (RADV POLARIS12) driver: mesa radv
    v: 24.0.2-manjaro1.1 device-ID: 1002:699f surfaces: xcb,xlib,wayland
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 8
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max:
    gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 1002:aae0 class-ID: 0403
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Dell RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek 802.11ac NIC driver: rtw_8821cu type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2 chip-ID: 0bda:c811
    class-ID: 0000 serial: <filter>
  IF: wlp0s20u3 state: up mac: <filter>
  Info: services: NetworkManager,wpa_supplicant
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4:3
    chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.51 TiB used: 11.09 GiB (0.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingfast model: N/A size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 1B0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Silicon Power
    model: SPCC Solid State Disk size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s tech: SSD serial: <filter> fw-rev: 9105
    scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Lexar model: USB Flash Drive
    size: 116.06 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
    fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 476.93 GiB size: 468.38 GiB (98.21%) used: 11.09 GiB (2.4%)
    fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.58 GiB used: 2.19 GiB (14.0%)
  Processes: 253 Power: uptime: 9m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.21 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1154 libs: 332 tools: pamac pm: flatpak pkgs: 0
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.33

Add a swapfile and make it 16GB.

If it’s still crashing after that run qtcreator from the console and post the output when it crashes.

So now you want me to install Qt Creator from the unified installer now? I can’t get far enough off of this install to make it crash because without kits I can’t even create a project. The crash happens only after I create a project and try to edit the qml file with designer. Besides, as far as I understand memory management, the application layer should have no idea whether the swap exists or doesn’t exist until it runs out of memory.

Where did I say that?

I have no idea what you’re talking about. The Desktop kit is installed by default. Create a project with default settings and double-click mainwindow.ui to open it in designer.

Not sure the application layer has any idea about swap. The memory management system does, and often uses it long before you run out of RAM. It’s actually for memory reclamation, ie more efficient use of RAM.

swap is off topic

We cannot possibly know why you have the issue - as it is not reproducable - so the recommendation still stands.

So - continuing to state it does not - ia a waste of your time and ours.

I just want to be able to use this. Appreciate all the help so far. It also seems that someone else has created a comment in the Qt Forum with similar issues.

You can - but if you go blind because Qt Quick Applications does not have a Desktop kit associated - then it is your error.

You can create a Qt Quck application for Desktop by using the Qt Quick compat template.

But it does appear to me that you need to research - before you claim there is a bug with Manjaro or the applications provided.

Ok but then what did I do wrong? I followed your directions.

You can create a Qt Quck application for Desktop by using the Qt Quick compat template.

I don’t understand this comment. I have created a lot of QML manually before but I wanted to try designer.

I am not claiming it is a bug (specifically) in manjaro. In fact technically I have proven the opposite. I had just hoped that someone here would have the insight to know why it isn’t working. Generally if I have a problem with an AUR package I leave a comment on the package page. But I couldn’t find comments for the qt packages so I came here.

Sorry I missed this comment before:

I have no idea what you’re talking about. The Desktop kit is installed by default. Create a project with default settings and double-click mainwindow.ui to open it in designer.

If the desktop kit is installed by default then why does my install have no kits to select when I try to create a project? Why does every attempt I make to add a kit end with an invalid symbol error?

As I have said (alot). The only way I can get kits is with the unified installer, but that doesn’t work either. Any OS package install I do has no kits.

If you have no idea then it must be a problem on the Qt side. I guess I will have to hope they answer the bug report I opened.

The default Desktop kit uses Qt5. Qt5 supports “QT Quick Application (compat)” only. Read the manual about how to add other Qt versions and kits.

  1. Add Qt6 (/usr/bin/qmake6)
  2. Add a new kit and change it’s Qt version to 6.