QGnomePlatform not working/not respecting dark theme?

Does not compute. Try creating a new user and see if you can reproduce it. If not, you have some user config overriding something.

gnome is valid, gtk3 is not. The avaliable values are gtk2, gnome, kde, qt5ct, or xcb.

Where did you come up with that, anyway? :thinking:

Same issue when on a separate account.

I know Manjaro moved away from qtct but I opened it up just to see what it said and currently it says the variable is at gnome. I’ve tried uploading an image to show but the forum wont let me.

Imagine that. :wink:

What theme do you have set for Legacy Applications in Tweaks? Try Adwaita / Adwwaita-dark or Adw / Adw-dark.

I tried switching to using Kvantum which worked, but the text is unreadable as its grey on black, I’ll go back to gnome and try the tweaks. I had default in both legacy and shell

Kate is stuck in light mode still, every other line in dolphin is white and still illegible (but side bar is fine) and konsole is still stuck on light (the title bar at least)

hm… good question. I used that in my custom AppImages, which seems to work in XFCE and Gnome and also in Ubuntu.

        export QT_QPA_PLATFORMTHEME=gtk3

So assumed it would be universal for all GTK3 applications and gtk2 works also. Maybe I am wrong here :man_shrugging:

Can you point to a list or documentation what values are actually valid? Seems it is hard to find official docs for that. Thanks :wink:

Setting it to qt5ct and setting it as kvantum with the libadaiwata theme makes it uniform but sadly the window decorations are stuck on the old one which I really hate.
Update: Setting the Shell to default and Legacy to Orchis Dark with Orchis Kvantum disabling composite effects makes it the most uniform I can get it to be. Editing Konsole profiles is screwed up but dolphin is fine

@TheKarion I am not a Gnome user but I think the idea behind all was to remove qt5ct and qt6ct packages and use QGnomeplatform instead and then the suggested solution by Yochanan should work as expected. Maybe I am wrong :thinking: . Give it a try, your choice of course.

qtct is still installed on testing and unstable branches, and I don’t think qgnomeplatform is working at all. Hopefully this’ll be fixed soon.

I saved the options I’ve come across. I haven’t been able to find documentation, either.


  • Available options: gtk2, gnome, kde, qt5ct, xcb


  • Available styles: HighContrastInverse, HighContrast, Adwaita-HighContrastInverse, Adwaita-HighContrast, Adwaita-Dark, Adwaita, kvantum-dark, kvantum, qt5ct-style, Windows, Fusion

The packages are still in the repos, they’re just not used by default for the GNOME ISO profile anymore.

It works for me and everyone else as far as I’ve seen.

Let us know how you resolve the issue. :wink:

@TheKarion For Kate and Konsole in Gnome, do you have anything other than ‘Default’ under Application Menu > Settings > Window Colour Scheme ?

Qgnomeplatform works as is, at least according to my tests. As a test, try installing Kwrite and it should automatically adopt the dark theming.

For Dolphin I can’t get it to apply the dark theme fully. Every second line is in white.

Note: I have qt5ct and qt6ct uninstalled and all QT_QPA_PLATFORMTHEME lines are deactivated in env.

So an update, I reinstalled manjaro went to testing and tried the same thing to no avail, trying unstable now. Kvantum is the only thing that seems to work, but even then settings pop out menus are all broken, as well as menu animations not applying

Can you send a screenshot of what it looks like?

@TheKarion See here:

KvColor Scheme


Note: It’s a VM fresh install with switching to testing branch and it utilizes Kvantum Manager for selecting Application Menu > Settings > (Window) Colour Scheme. Maybe there is other solutions.
Dolphin has some issues but I wasn’t spending more time to try different settings.

It looks much like Gnome style, isn’t it?

Looks like old gnome screwed up. Here’s mine

I have the following:

cat /etc/environment                                             ✔ 
# This file is parsed by pam_env module
# Syntax: simple "KEY=VAL" pairs on separate lines



# Force to use Xwayland backend

#Not tested: this should disable window decorations

  • qt5ct and qt6ct removed
  • Kvatum manager installed (works out of the box)
  • Kate, Konsole etc choose in application settings a respective dark theme as color scheme
  • Dolphin I don’t know yet

Yes you can overwrite all Qt applications with QT_STYLE_OVERRIDE=“kvantum”. You will have to select and adjust your default theme in the Kvantum Manager. It’s all your choice.

If you like Kde applications so much you may try Plasma 5 :wink:

I’ve been using KDE for a long time, but I prefer the consistency of Gnome, KDE keeps crashing applications all the time lol. Can you post your .profile (should be in your home folder) if you have one?

1 Like

No .profile exists.

Plasma runs very consistent in my case, apart from minor visual glitches which do not impact it’s functionality. I can’t complain about it.



In KV Manager choose Theme ‘KvGnomeDark’ to use this theme.
The rest is done in Tweaks.

The result:

Papirus Maia Green


1 Like

Same went to kde plasma and it runs just fine, haven’t had a crash yet. With the newest kvantum-qt5-git update the cropping on buttons was fixed so it looks a lot better.

Solution: Switch to KDE or use kvantum with some inconsistencies,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.