Qemu/kvm (virt-manager) very slow after update - AMD Ryzen

I am using an up-to-date version of manjaro mate and have virt-manager 3.2.0-1 installed on my Thinkpad E14 (AMD Ryzen 5 4500U). Using either GNOME Boxes or virt-manager it is really slow:

It really bothers me because I know it just work flawlessly in the past. Unfortunately I don’t know what update caused this issue. I did a reinstall but the issue still persists. I tried using Ubuntu MATE but it is also very slow there. I used quickemu as well and it just worked perfect back then, currently installation fails.

I do not know whether this issue has something to do with this one. But there I got a error

/usr/share/libdrm/amdgpu.ids: No such file or directory

and actually amdgpu.ids is located in/var/lib/mhwd/ids/pci/amdgpu.ids.

I know the data availability is not great but maybe someone with AMD Ryzen experiences similar issues that can be resolved.

Thanks for any ideas!

EDIT 27/3:
I tried using virtualbox and there are no performance issues, however I really prefer using GNOME Boxes or virt-manager.