Qcad cannot open or save using the actual system file dialog

Once Installed Qcad by the official package manager I noticed all folders were missing when I tried to open a file.

I tried to save a simple draw, but some weird issue happened
Unable to create io-slave. Unknow protocol 'file'.

I ask some users to install Qcad and they did and had the same problem, one them said me the package came from the Arch and none Arch user report any issue about it, so its more likely to be a Manjaro issue

A workaround would be:

QCAD uses the default file dialog offered by the system. If the file dialog is broken (for whatever reasons), you can force the use of the Qt file dialog instead under:
Edit > Application Preferences > File > Load/Save > [ ] Use system file dialog (untick)

The last comes from qcad bugtracker: FS#1546 : 'Open file' dialog shows no files - although the directory displayed is full of .dxf files, which has a similar issue but is pretty old (2017) and also OS is different, things in common are Dolphin and KDE Plasma, probably both in old versions nowadays.

I would like to know what would be causing this issue and how to solve it. Any idea?

1 Like

I installed qcad from pamac-manager, just to try. I noticed that in the first screen (units setup screen), I couldn’t see anything, as if the dialog stuff were transparent. I saved it as it is, and started the application, I didn’t face what you are mentioning. Could it be because you are using light theme on your system? Please note that I use dark theme on my system.

When you try to open something, and you face the empty dialog, try to select all (Ctrl+A, or with the mouse)… Are the icons transparent ?

Another note, try to change the theme from

Edit | Application Preferences | General | Theme

I couldn’t find out theme option per application

Instead I change global theme to breath 2 2021 dark

I still have this empty dialog. I tried reinstalling Qcad with no luck

I tried selecting everything inside, but it seems to be real empty, nothing were selected.

To prove it. I click on the box dialog and use Ctrl+A to select everything inside and then tried to erase them, but nothing happened

I read this somewhere on arch forum:

start kdeinit4 from konsole after login. 
It will allow DOlphin and other apps to work.

I was searching for io-slave issues…
Try and let’s see ? I have no problem because probably I am using i3wm

kdeinit4 does not work on konsole, maybe it changed a little bit

sudo kdeinit4
sudo: kdeinit4: command not found

When I try to create a new folder the io slave error jumps, when I try to save a file with a new name it shows a warning saying it cant create it.

The error is happening even outside QCad ?
You mean, in file browser, io slave error jumps when you create a folder ?

No, just inside Qcad file manager. But I starting to believe this is some kind of issue between modern versions of dolphin and qcad. I could probably get this working on an old version of dolphin .

This is how looks like when I tried this workaround

It looks pretty old, at least not what I’m used to see Dolphin nowadays.

But even managing getting work the save/open files I couldn’t figure out why the script reader is still unusable

As you see, I still get this white screen not showing directories neither files

I know this may be off-subject, and not an answer, but did you consider trying librecad? it is very similar to qcad in concept. At least, try and see if you would face the same problem.

Librecad works fine with no issues.

Edit: I noticed the save/open file dialog is not the same as my system

When I open the save/open file dialog it shows a warning saying
couldn't create slave: "Unknown protocol 'file'."

A previous warning saying (Warning: Could not find any platform plugin) happens when clicking any button in the toolbar

$ qcad                                                                                            
QCAD version
00:27:35: Debug:    CadToolBar.initStyle
00:27:35: Debug:    EcmaScriptShell.initStyle:
Warning:  Could not find any platform plugin
Warning:  couldn't create slave: "Unknown protocol 'file'."
00:29:14: Debug:    done

Unfortunately, I am not able to reproduce your error as I am using i3wm. I think qcad and your version of Dolphin are not compatible, or probably there is some missing library.

1 Like

Thanks for your help, I think Qcad dev doesnt support third party packages so I guess Im on my own right now. I will try later their binary version for linux, or maybe I ll just compile from sources, I still think I’ll get the same results. In any case I know its because some issues between Dolphin and Qcad, my final try will be on a virtual machine in debian with gnome, that should work out the box