Qbittorent Couldn't write file. Permision denied. Torrent is curenctly in ''upload mode only''

Hello, i have some problems with my disk permissions, i guess its related to software applications so i am asking here. Perhaps someone could help me.

I have two disks, one SSD where all the main system is installed and HDD. HDD is empty for now. Whenever i set the download path to SSD everythign works fine and qbittorents downloads fine. But whenever i set the download path to the HDD i get the error Couldn’t write file. Permision denied. Torrent is curenctly in '‘upload mode only’'

So i know that this has something to do with HDD file permissions. I tried some ways to fix but following some guide on the net but with no success. The HDD is automatically mounted on boot as /data after i write the key for its encryption.
I had problems at first with it where i could not even create file but then i changed the permissions so the owner is /root and the group to user.

What could i do to fix this issue ? From my understanding qbittorent runs as user so it should be able to download the files to there just like i could make a new folder there as a user.

1 Like

Set permissions to your user:

sudo chown -R -v $USER:$USER /path/to/hdd

Anyone can write and read:

sudo chmod -R  -v 777 /path/to/hdd
4 Likes

Thank you, it seems the problem was caused by firejail not allowing to write in there, don’t know how i fixed it but i did it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.