Python2-pycparser update failing

While running pacman updates google-chrome, python2-attrs, & python2-pycparser fail to install ends with:>

`> FAIL: test_all_examples (tests.test_examples.TestExamplesSucceed)

Traceback (most recent call last):
File “/var/tmp/pamac-build-bob/python2-pycparser/src/pycparser-release_v2.21/tests/”, line 29, in test_all_examples
rc, 0, ‘example “{}” failed with stdout =\n{}’.format(filename, stdout))
AssertionError: example “” failed with stdout =

Ran 130 tests in 1.064s

FAILED (failures=1)
==> ERROR: A failure occurred in check().

(As you can see, this is the “traceback”. If you need to see all of it, let me know.)

This started a couple weeks ago. Since then there has been a major update. I thought the major update might resolve the issue but no, it did not.

Been using Linux for many, many years however I am a newbie when it comes to Manjaro. Been using it for about a year. I really like the rolling updates.

So, any suggestions on what I can do to correct this?

None of these packages that you mention are essential.
And none of these is even in the Manjaro repositories
Those are all packages installed from the AUR - and it is not pacman that you used to install those but perhaps pamac.

If you just want to update you can remove these packages (temporarily)
and deal with rebuilding them later.

Google-chrome is not responsible for the failure, but some of the python stuff …
perhaps you don’t even need it anymore?

Just approach them one at a time, instead of all at once.
I’m sure google-chrome will install but one or more of the python2 packages will not.

See the pinned comment on the AUR page.

1 Like

I’m not using chrome, but i have same issue here with python2-pycparser 2.21-1
here is pamac output:

Traceback (most recent call last):
  File "/var/tmp/pamac-build-mody/python2-pycparser/src/pycparser-release_v2.21/tests/", line 29, in test_all_examples
    rc, 0, 'example "{}" failed with stdout =\n{}'.format(filename, stdout))
AssertionError: example "" failed with stdout =
AST before change:
      Decl: foo, [], [], []
            Decl: a, [], [], []
              TypeDecl: a, []
                IdentifierType: ['int']
            Decl: b, [], [], []
              TypeDecl: b, []
                IdentifierType: ['int']
          TypeDecl: foo, []
            IdentifierType: ['void']
      Decl: bar, [], [], []
          TypeDecl: bar, []
            IdentifierType: ['void']

Ran 130 tests in 0.649s

FAILED (failures=1)
==> ERROR: A failure occurred in check().

any help would be greatly appreciated

It has already been given - in the post right above yours.

Hi - I had a similar issue a couple of updates back, with a bunch of python2 packages that had come in through the AUR blocking up updates. In my case, I think that they were all actually no longer needed - I used pacman -Qii [package-name] to see if they were required by any other packages. (Some were required by other python2 packages but I could follow the chain along to check that ultimately nothing would be affected by removing them.) When I ascertained that they were safe to install, I removed them using the pamac gui.

This said, I’m a fairly novice/non-technical user, so perhaps do a bit of checking yourself, and if possible do a backup etc., before charging ahead and fiddling with something you don’t fully understand. But it’s what worked for me!

that’s right … but the problem her is i don’t know what is that “clean chroot”, so for someone novice I find it hard to follow those steps.I don’t even know what caused that problem in first place.

thanks Lukewhite.
I did the same steps that you did. I’ve tracked and deleted all packages that depend on the Python2-pycparser ,then removed that ‘‘Python2-pycparser’’
But honestly, I don’t know if that’s the right thing to deal with this problem.

of course no one is born with all the knowledge, every one has had to learn …
which is made a little bit easier in this case because there is even a link to the relevant wiki

I don’t think they do as well - but it is not important and they are not trying to find out either
as the package does build just fine
in a “clean chroot”

btw: a possible fix was to disable building the tests - because these fail, after the build

But perhaps you don’t even need that software anymore … I’d make sure to know before I invest time and effort into this.

Back now to close my part of this thread.

I chose to not install the python2-pycparser package and proceeded with installation of google-chrome and python2-attrs packages. That install proceeded as normal and completed. Now my Google-chrome has been updated.

Then I attempted to install python2-pycparser by itself. During the graphic pacman install process there is a button to choose to check the build script. I ‘commented out’ the check line as suggested [here] in the first line of bionade24 comment. And python2-pycparser package then installed without issue.

Someone may suggest a different method but, this corrected my issue (remember, I am a newbie to Manjaro) this worked for me in my situation. I am no longer getting any warnings of installation issues.

1 Like

mnjrbob- I followed your suggestion re: the change to the build script. Finally updated, thank you!

python2 is already end-of-life now. Every package depending on python2 should be removed (unless they are essential for your work).