Python-pip install (upstream) error?

I am trying to install python-pip on my manjaro system. This is so I can use pip to install other python packages. I am seeing the following error which, to me, looks like it may be upstream:

:: Proceed with installation? [Y/n] y
(19/19) checking keys in keyring                         [##############################] 100%
(19/19) checking package integrity                       [##############################] 100%
error: python-distlib: signature from "Felix Yan <felixonmars@archlinux.org>" is invalid
:: File /var/cache/pacman/pkg/python-distlib-0.3.1-2-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

The error occurs if I choose not to delete that file as well. I am somewhat new to the workflow of aur packages, if this is an upstream error, what’s my course of action? If it’s not, any ideas why I might be seeing this error?

I am running a clean version of manjaro in a virtual machine.

Welcome to the Forum!

Follow the instructions from the following tutorial to solve your issue:

Remember to not install python modules using sudo pip as it will - long term - cause conflicting files during system sync.

All common python modules are available using pacman

pacman -S python-<module-name>

Use virtual environments which also removes the necessity for a system wide python-pip.

This did not solve the issue. To clarify the package that’s causing the issue is a dependency of the arch user repository for python-pip (Arch Linux - python-pip 20.3.4-1 (any)). So clearing my cached packages does not make the install work.

You are confusing AUR with the official Arch repo - and there is no issues installing the python-pip from Manjaro repo.

➜  ~ sudo pacman -S python-pip  
resolving dependencies...
looking for conflicting packages...

Packages (13) python-cachecontrol-0.12.6-5  python-colorama-0.4.4-3
              python-contextlib2-0.6.0.post1-3  python-html5lib-1.1-8
              python-msgpack-1.0.2-2  python-pep517-0.11.0-1
              python-progress-1.6-1  python-resolvelib-0.5.5-1
              python-retrying-1.3.3-9  python-toml-0.10.2-3
              python-tomli-1.2.1-1  python-webencodings-0.5.1-6
              python-pip-20.3.4-1

Total Installed Size:  3,82 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 python-msgpack-1.0.2-2-x86_64 is up to date
 python-toml-0.10.2-3-any is up to date
 python-pep517-0.11.0-1-any is up to date
 python-colorama-0.4.4-3-any is up to date
 python-resolvelib-0.5.5-1-any is up to date
 python-tomli-1.2.1-1-any is up to date
 python-webencodings-0.5.1-6-any is up to date
 python-contextlib2-0.6.0.post1-3-any is up to date
 python-progress-1.6-1-any is up to date
 python-retrying-1.3.3-9-any is up to date
(13/13) checking keys in keyring                   [----------------------] 100%
(13/13) checking package integrity                 [----------------------] 100%
(13/13) loading package files                      [----------------------] 100%
(13/13) checking for file conflicts                [----------------------] 100%
(13/13) checking available disk space              [----------------------] 100%
:: Processing package changes...
( 1/13) installing python-msgpack                  [----------------------] 100%
( 2/13) installing python-cachecontrol             [----------------------] 100%
Optional dependencies for python-cachecontrol
    python-lockfile: for the FileCache
( 3/13) installing python-colorama                 [----------------------] 100%
( 4/13) installing python-contextlib2              [----------------------] 100%
( 5/13) installing python-webencodings             [----------------------] 100%
( 6/13) installing python-html5lib                 [----------------------] 100%
Optional dependencies for python-html5lib
    python-lxml: lxml treebuilder [installed]
    python-genshi: genshi treewalker
( 7/13) installing python-tomli                    [----------------------] 100%
( 8/13) installing python-pep517                   [----------------------] 100%
( 9/13) installing python-progress                 [----------------------] 100%
(10/13) installing python-retrying                 [----------------------] 100%
(11/13) installing python-resolvelib               [----------------------] 100%
(12/13) installing python-toml                     [----------------------] 100%
(13/13) installing python-pip                      [----------------------] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
1 Like

Thanks! Didn’t know that. This solved the issue.

This does not work for me. This is the command I’m running when I see the error I posted about above.

The message you describe is a local issue on your system and is not caused by the repo.

Consider the troubleshooting linked by @bill_t.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.