PulseAudio vs. PipeWire - Which To Use?

Hey Guys,

I wanted to understand it seems like the community is pushing for users to switch from PulseAudio to Pipewire. Is this still the case, and if so Why? I am just trying understand the advantages on why to use one over the other.

Thank you in advance to everyone for your time and help, it is super appreciated.

Thanks,
Asif

2 Likes

Many switched to PipeWire after PulseEffects (now EasyEffects) dropped support for PulseAudio and begin supporting PipeWire instead.

I still use PulseAudio personally, it’s still working.

https://wiki.archlinux.org/title/PulseAudio
https://wiki.archlinux.org/title/PipeWire

2 Likes

I switched to PipeWire almost immediately after I installed Manjaro.
I had problems with PulseAudio - interruptions and glitches in games when there are a lot of sound sources.
Also in the HD mod for Diablo 2 there was no sound at all.
(On my PC, a videocard is responsible for playback via DisplayPort .)
It’s all good now.

1 Like

I switched to pipewire from the start since I installed manjaro because when I was in another distro had crackling sound due pulseaudio and only pipewire fixed it (I had to restart pulseaudio constantly)

I didn’t know PulseEffects dropped support (@maycne.sonahoz)

i switched to pipewire after obs-studio was modified to require it. i saw no reason to run both.

1 Like

Should Pulse Audio be removed, prior to installing Pipewire?

Just install manjaro-pipewire. Answer yes to replacement questions. It will remove pulseaudio packages and install the pipewire equivalents in a single transaction.

5 Likes

But it seems that the sound config on Plasma only supports Pulseaudio and if you use pipewire there is no sound icon on the system tray.

Still got one on mine(KDE Plasma).

No, works fine for me.

1 Like

Changed to PipeWire, very good until I try to play the only game I play, factorio. No sound in factorio with PipeWire. Went back to PulseAudio. Now I have sound in factorio again.

Works fine for me. I’ve been using PipeWire on KDE for months.

I don’t even know what I’m using :laughing:

Sound is working everywhere as desired, so I’m fine.

You also get lower latency and support for jack applications, as pipewire and replace both jack and pulse.

Another reason to use Pipewire is better bluetooth codec support. By default, Pulse supports just the SBC codec. Pipewire supports virtually all bluetooth codecs by default.

This is strange, because under EndeavourOS (Arch), where Pipewire is now standard, there is a sound icon in the tray as usual.
Btw, it works fine with my K5 Pro DAC.

I have pipewire installed on Manjaro and still have a sound icon in my tray.

1 Like

I - The standard KDE audio volume control is no longer available;
II - We no longer have the audio configuration options (hardware) in the “System Settings”;
III - When we add a new audio device (a bluetooth headset, for example) it does not start to be used automatically by the OS;
IV - The keyboard features/keys for audio control have stopped working.

I’m terribly sorry, but in Arch KDE I still have the icon. How can I fix this? Would that help you to make me stand in the corner and feel all bad? :worried:

It’s also missing the sound icon for me, and I can’t control the volume using my keyboard shortcut anymore. This was after sudo pamac remove pulseaudio && sudo pamac install manjaro-pipewire && reboot