PulseAudio Volume Control output port not detecting headphones automatically

The OS doesn’t detect headphones instantly whenever I plug my headphones in the 3.5mm jack. I have to manually go every time to PulseAudio Volume Control -----> Output devices -----> Port. And change it from Speaker to Headphones. The problem didn’t exist before the last major update (giant 1+GB one).

Here is my system info by inxi -Fazy:

      Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
      parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
      root=UUID=b7f8ad79-6fb0-4053-b2f4-b41cd7833b15 rw quiet apparmor=1 
      security=apparmor udev.log_priority=3 
      Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: vala-panel, xfce4-panel, plank 
      wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
      Type: Laptop System: Dell product: Inspiron 5559 v: N/A serial: <filter> 
      Chassis: type: 10 serial: <filter> 
      Mobo: Dell model: 0924RG v: A00 serial: <filter> UEFI: Dell v: 1.5.2 
      date: 07/18/2018 
      ID-1: BAT0 charge: 25.4 Wh condition: 34.6/32.6 Wh (106%) volts: 15.9/14.8 
      model: LGC-LGC2.80 DELL 991XP55 type: Li-ion serial: <filter> 
      status: Charging 
      Info: Dual Core model: Intel Core i3-6100U bits: 64 type: MT MCP 
      arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: D6 
      L2 cache: 3072 KiB 
      flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
      bogomips: 18406 
      Speed: 500 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 
      4: 500 
      Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
      Type: l1tf 
      mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
      Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
      Type: meltdown mitigation: PTI 
      Type: spec_store_bypass 
      mitigation: Speculative Store Bypass disabled via prctl and seccomp 
      Type: spectre_v1 
      mitigation: usercopy/swapgs barriers and __user pointer sanitization 
      Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
      IBRS_FW, STIBP: conditional, RSB filling 
      Type: srbds status: Vulnerable: No microcode 
      Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
      Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 
      v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
      Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 
      520 Mobile] 
      vendor: Dell driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 
      chip ID: 1002:6660 
      Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
      bus ID: 1-5:3 chip ID: 0bda:5684 serial: <filter> 
      Display: x11 server: X.Org 1.20.9 driver: ati,intel,radeon 
      unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
      Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
      s-diag: 414mm (16.3") 
      Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
      diag: 389mm (15.3") 
      OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.1 
      direct render: Yes 
      Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
      v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d70 
      Sound Server: ALSA v: k5.8.18-1-MANJARO 
      Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: e000 
      bus ID: 02:00.0 chip ID: 8086:08b3 
      IF: wlp2s0 state: up mac: <filter> 
      Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
      driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8136 
      IF: enp3s0 state: down mac: <filter> 
      Local Storage: total: 931.51 GiB used: 168.22 GiB (18.1%) 
      SMART Message: Required tool smartctl not installed. Check --recommends 
      ID-1: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB 
      block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
      rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
      ID-1: / raw size: 63.48 GiB size: 62.23 GiB (98.04%) used: 18.67 GiB (30.0%) 
      fs: ext4 dev: /dev/sda8 
      ID-2: /home raw size: 92.58 GiB size: 90.62 GiB (97.89%) 
      used: 30.34 GiB (33.5%) fs: ext4 dev: /dev/sda9 
      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
      ID-1: swap-1 type: partition size: 8.01 GiB used: 8.3 MiB (0.1%) 
      priority: -2 dev: /dev/sda7 
      System Temperatures: cpu: 44.0 C mobo: 41.0 C sodimm: 37.0 C gpu: radeon 
      temp: 42.0 C 
      Fan Speeds (RPM): cpu: 0 
      Processes: 226 Uptime: 5h 19m Memory: 7.67 GiB used: 3.18 GiB (41.4%) 
      Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
      pacman: 1584 lib: 374 flatpak: 0 Shell: Bash v: 5.0.18 
      running in: xfce4-terminal inxi: 3.1.08 

By mhwd -lh -d --pci

16: PCI 1f.3: 0403 Audio device
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel Sunrise Point-LP HD Audio"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9d70 "Sunrise Point-LP HD Audio"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x06b2 
  Revision: 0x21
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xdf320000-0xdf323fff (rw,non-prefetchable)
  Memory Range: 0xdf300000-0xdf30ffff (rw,non-prefetchable)
  IRQ: 132 (3276 events)
  Module Alias: "pci:v00008086d00009D70sv00001028sd000006B2bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Driver Info #1:
    Driver Status: snd_soc_skl is active
    Driver Activation Cmd: "modprobe snd_soc_skl"

Hi, I’m new to manjaro so sorry if i’m wrong. I was facing similar issue and wanted to detect my earphones automatically, so i looked up stuff and found that you have to go to
System Settings -> Audio -> Advanced and here click on Automatically switch all running streams when a new output becomes available box.

Now I think it is switching to my earphones for output whenever i connect it, but i think for the input it is still using the internal which I don’t want it to do, and instead use my earphone microphone, manually changing it each time through Pulse volume control becomes a headache. Can anyone help me with this?

Edit: To add, Whenever i connect my wired earphones, the sound becomes muted and I have to manually click on the audio icon from taskbar and unmute the sound, is it the expected behaviour? how can i change it if so?

Yeah. Same problem. But I think this problem is solved now if you’re on latest update as of 3rd December. It is solved for me.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.