Pulseaudio stopped working (not connected to pulseaudio server)

This is the error massage that i’ve got.


image

inxi -Fazy

[hunor@HunorT480 ~]$ inxi -Fazy
System:
  Kernel: 5.15.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=cc7be21e-d9d4-4881-841a-b047d2a1253a rw quiet
    udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20L6S1LV2F v: ThinkPad T480
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20L6S1LV2F v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N24ET67W (1.42 )
    date: 11/17/2021
Battery:
  ID-1: BAT0 charge: 14.5 Wh (78.0%) condition: 18.6/23.9 Wh (77.6%)
    volts: 11.9 min: 11.4 model: LGC 01AV489 type: Li-poly serial: <filter>
    status: Not charging cycles: 75
  ID-2: BAT1 charge: 14.1 Wh (62.7%) condition: 22.5/24.0 Wh (93.9%)
    volts: 11.4 min: 11.5 model: SMP 01AV452 type: Li-poly serial: <filter>
    status: Discharging cycles: 184
CPU:
  Info: model: Intel Core i5-8350U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1174 high: 1565 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1565 2: 1414 3: 1381
    4: 800 5: 800 6: 800 7: 1368 8: 1269 bogomips: 30409
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Chicony Integrated Camera (1280x720@30) type: USB
    driver: uvcvideo bus-ID: 1-8:4 chip-ID: 04f2:b604 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158
    size: 309x174mm (12.2x6.9") diag: 355mm (14")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo ThinkPad T480
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.19-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.45 running: no
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d7 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 03:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 238.47 GiB used: 43.12 GiB (18.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKKF256G8L
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: L15P temp: 32.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 118.93 GiB size: 116.5 GiB (97.96%) used: 43.1 GiB (37.0%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.3 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 46.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 244 Uptime: 5m wakeups: 3 Memory: 7.51 GiB used: 2.04 GiB (27.2%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0
  Packages: pacman: 1165 lib: 322 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.12

I recently installed and configured i3, but that was in another user.

EDIT:
I have sound, but i cant turn the volume up.

What does systemctl --user restart pulseaudio return? longshot but can you install manjaro-pulse and reboot


[hunor@HunorT480 ~]$ systemctl --user restart pulseaudio
Job for pulseaudio.service failed because the control process exited with error code.
See "systemctl --user status pulseaudio.service" and "journalctl --user -xeu pulseaudio.service" for details.
[hunor@HunorT480 ~]$ sudo systemctl --user restart pulseaudio
[sudo] password for hunor: 
Failed to connect to bus: No medium found

Share these systemctl --user status pulseaudio.service and journalctl --user -xeu pulseaudio.service

[hunor@HunorT480 ~]$ 
[hunor@HunorT480 ~]$ systemctl --user status pulseaudio.service
Γ— pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor>
     Active: failed (Result: exit-code) since Wed 2022-02-09 18:40:59 CET; 2min>
TriggeredBy: Γ— pulseaudio.socket
    Process: 94245 ExecStart=/usr/bin/pulseaudio --daemonize=no --log-target=jo>
   Main PID: 94245 (code=exited, status=1/FAILURE)
        CPU: 45ms

Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Scheduled restart j>
Feb 09 18:40:59 HunorT480 systemd[926]: Stopped Sound Service.
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Start request repea>
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Failed with result >
Feb 09 18:40:59 HunorT480 systemd[926]: Failed to start Sound Service.

[hunor@HunorT480 ~]$ sudo systemctl --user status pulseaudio.service
Failed to connect to bus: No medium found

[hunor@HunorT480 ~]$ journalctl --user -xeu pulseaudio.service
Feb 09 18:40:59 HunorT480 systemd[926]: Stopped Sound Service.
β–‘β–‘ Subject: A stop job for unit UNIT has finished
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: Support - Manjaro Linux Forum
β–‘β–‘
β–‘β–‘ A stop job for unit UNIT has finished.
β–‘β–‘
β–‘β–‘ The job identifier is 433 and the job result is done.
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Start request repea>
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Failed with result >
β–‘β–‘ Subject: Unit failed
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: Support - Manjaro Linux Forum
β–‘β–‘
β–‘β–‘ The unit UNIT has entered the β€˜failed’ state with result β€˜exit-code’.
Feb 09 18:40:59 HunorT480 systemd[926]: Failed to start Sound Service.
β–‘β–‘ Subject: A start job for unit UNIT has failed
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: Support - Manjaro Linux Forum
β–‘β–‘
β–‘β–‘ A start job for unit UNIT has finished with a failure.
β–‘β–‘
β–‘β–‘ The job identifier is 433 and the job result is failed.
lines 476-498/498 (END)

Have you modified PulseAudio configuration files daemon.conf or default.pa ?

I suggest you check pulseaudio.socket and pulseaudio.server for error messages

systemctl -l --no-pager --user status pulseaudio.{socket,service}

It might also help to clear old PulseAudio database settings from user home folder

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

and reboot system so PulseAudio creates new database files when retarted

no.
I changed β€œautospawn = no” to β€œyes” and back to β€œno”.

[hunor@HunorT480 ~]$ sudo rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie
[sudo] password for hunor: 
rm: cannot remove '/home/hunor/.config/pulse/*.tdb': No such file or directory

[hunor@HunorT480 ~]$ systemctl -l --no-pager --user status pulseaudio.{socket,service}
Γ— pulseaudio.socket - Sound System
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
     Active: failed (Result: service-start-limit-hit) since Wed 2022-02-09 18:40:59 CET; 7min ago
   Triggers: ● pulseaudio.service
     Listen: /run/user/1000/pulse/native (Stream)

Feb 09 18:40:58 HunorT480 systemd[926]: Listening on Sound System.
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.socket: Failed with result 'service-start-limit-hit'.

Γ— pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Wed 2022-02-09 18:40:59 CET; 7min ago
TriggeredBy: Γ— pulseaudio.socket
    Process: 94245 ExecStart=/usr/bin/pulseaudio --daemonize=no --log-target=journal (code=exited, status=1/FAILURE)
   Main PID: 94245 (code=exited, status=1/FAILURE)
        CPU: 45ms

Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
Feb 09 18:40:59 HunorT480 systemd[926]: Stopped Sound Service.
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Start request repeated too quickly.
Feb 09 18:40:59 HunorT480 systemd[926]: pulseaudio.service: Failed with result 'exit-code'.
Feb 09 18:40:59 HunorT480 systemd[926]: Failed to start Sound Service.

I changed to my other user and it’s working properly,
Did I messed something while installing i3+xfce on the other user?

Can you remove your pulse config and reboot:

mv ~/.config/pulse ~/.config/pulse_backup
reboot

I love you man!

pulseaudio.socket is enabled correctly but cannot start pulseaudio.service and gave up after 5 attempts

pulseaudio.service is showing Stopped Sound Service
did you use a command pulseaudio -k or pulseaudio --kill to attempt to stop PulseAudio daemon directly ?

sudo is not needed for deleting user files in home directory

check the contents of the folder:

ls ~/.config/pulse/

It should contain 3 .tdb database files to store user preferences for audio devices with the Pulseaudio cookie number in the name :

  • e1a1dbd021524f58a519eccfea07f8ea-card-database.tdb
  • e1a1dbd021524f58a519eccfea07f8ea-device-volumes.tdb
  • e1a1dbd021524f58a519eccfea07f8ea-stream-volumes.tdb

I changed β€œautospawn = no” to β€œyes” and back to β€œno”

Please post response to this command to show daemon.conf configuration

cat /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf
[i3hunor@HunorT480 ~]$ ls ~/.config/pulse/
cookie                                              f4fc093c1c8e4f35a5ec418049c93a38-default-sink    f4fc093c1c8e4f35a5ec418049c93a38-device-volumes.tdb
f4fc093c1c8e4f35a5ec418049c93a38-card-database.tdb  f4fc093c1c8e4f35a5ec418049c93a38-default-source  f4fc093c1c8e4f35a5ec418049c93a38-stream-volumes.tdb

It seams like it contains something like that.

[i3hunor@HunorT480 ~]$ cat /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; enable-memfd = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; avoid-resampling = false
; enable-remixing = yes
; remixing-use-all-sink-channels = yes
; remixing-produce-lfe = no
; remixing-consume-lfe = no
; lfe-crossover-freq = 0

; flat-volumes = no

; rescue-streams = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0
cat: /home/i3hunor/.config/pulse/daemon.conf: No such file or directory

Contents of ~/.config/pulse/ appear to be as expected with database.tdb files present, so PulseAudio has probably restarted successfully to recreate the absent files

If status of pulseaudio.socket and pulseaudio.service both report as active (running) you should be able to party on no problem now

To restart PulseAudio use either

systemctl --user restart pulseaudio

or

pactl exit

instead of a kill command

1 Like

Thanks!
I really appreciate your time.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.