Pulseaudio not working with iQaudio DAC Pro, Alsa problems also?

I want to run mopidy through pulseaudio.

So, i change the /boot/config.txt like this:

 cat /boot/config.txt 
# See /boot/overlays/README for all available options


initramfs initramfs-linux.img followkernel
# Disable compensation for displays with overscan
# Uncomment to enable bluetooth

# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.

# Run as fast as firmware / board allows

I config mopidy to send to pulseaudio and put pulseaudio to hear.
But from pulseaudio im getting a “dummy output” (with no sound…), but receiving from mopidy (that is working…)

Also if i do, i get:

aplay -l
aplay: device_list:274: no soundcards found...

But if i run alsamixer i get (it is there):

Also create asound.conf in /etc like this:

cat /etc/asound.conf 
pcm.!default {
  type hw card 0
ctl.!default {
  type hw card 0


lsmod | grep snd
snd_soc_pcm512x_i2c    16384  1
snd_soc_pcm512x        32768  1 snd_soc_pcm512x_i2c
snd_soc_iqaudio_dac    16384  0
snd_soc_bcm2835_i2s    16384  2
snd_bcm2835            24576  0
snd_soc_hdmi_codec     16384  0
snd_soc_core          225280  5 snd_soc_pcm512x,vc4,snd_soc_iqaudio_dac,snd_soc_hdmi_codec,snd_soc_bcm2835_i2s
snd_compress           20480  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm               114688  7 snd_compress,snd_soc_pcm512x,snd_pcm_dmaengine,snd_soc_hdmi_codec,snd_soc_bcm2835_i2s,snd_bcm2835,snd_soc_core
snd_timer              32768  1 snd_pcm
snd                    77824  7 snd_compress,snd_soc_pcm512x,snd_soc_hdmi_codec,snd_timer,snd_bcm2835,snd_soc_core,snd_pcm


cat /proc/asound/cards
 0 [IQaudIODAC     ]: IQaudIODAC - IQaudIODAC

So… what is going on here?

Oh, if i run aplay as sudo i get:

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 [IQaudIO DAC HiFi pcm512x-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So, why pulseaudio is not working? and is given me that dummy output?