Pulseaudio "feedback" error/bug(?)

Hello, I’m new to Linux but decided to go with Manjaro as it worked great so far.
Until I decided to edit the pulseaudio config file to output high resolution audio. I decided to “test arround” with the help of the wiki with the “default sample format” to see if I could get it to output DTS or DD to my AVR. It couldn’t and it ended up playing sounds on repeat, so I changed it to what I wanted to do originally and rebooted.
Now it may have worked but I decided one last time to update the config to disable the Stereo remixing. And ever since it does the exact same thing as it did when I “experimented” with the DD and DTS codecs.

I’ve uploaded a video on YouTube to show this, given how I can only describe it like this:
It takes audio that played and just feeds it back, duplicating itself. Every new sound thats played will also get dublicated.
Here’s the link, it’s better to see/hear instead of me trying to describe it, (please mind that the video is loud): Pulse Audio bug Manjaro - YouTube

My questions now are:

  • First: what did I break and how do I (permanently) fix this issue? I know that I broke it, no point in denying that. But: I’ve edited the daemon.conf file on an older version of Manjaro but on the same computer before and it didn’t do it, so it’s 100% related to my messing around with the sample format. Which leads to the next quesion:
  • Are there any pulse-related files stored that apply system wide no matter what is set in /etc/pulse or rather: are there any fallback options that could have been edited?
    I only ever edited the files in /etc/pulse, nowhere else as far as I know.
    Last but not least: How to proceed from here…

I set up Timeshift… But I also copied the original daemon.conf and default.pa files before breaking them. And I restored the daemon.conf file from that backup. But that didn’t fix it. So I’m wondering if Timeshift could even help. So should I even attempt to restore a snapshot?

I’d really hate if I had to reinstall Manjaro. Because I use my PC through my AVR, it’s almost impossible to get video back on screen after the GRUB-menu is gone. Plus I just fixed another issue with my NVidia-GPU so I would probably have to figure that out again as well.

I really want to like Manjaro. Especially KDE-Manjaro worked best for me so far…

If there’s anything I forgot to add, I’ll add it here later. (
And sorry if the spelling is incorrect, but English isn’t my first language…)

Edit already: I’m not sure if I actually uncommented the line so this may have happened unrelated to my screw up… But I doubt that I wouldn’t have noticed that…

Hello @Mode2210 and welcome :wink:

Erm… sorry, my glass globe is at the repair shop, so my magical possibilities are limited. Care to share what you changed?

Bad habit. If you want to mess with that, then copy it to your home folder.

cp /etc/pulse/default.pa ~/.config/pulse/default.pa

Do your changes there and restart pulseaudio:

systemctl restart --user pulseaudio.service
systemctl status --user pulseaudio.service
1 Like

Thank you for your quick and kind response :smiling_face:

Yeah, I suppose I should have shared that as well…

I originally intended to change the default audio output to 24-bit with a sample rate of 176400 kHz… I did that once before and it worked (more or less) and that’s what I changed, as well as the setting:

enable-remixing = no

After using

pulseaudio -k

it still continued doing that. (Keep in mind that this was after I messed with the default sample format.)

I had made backups of the original files to a folder on my Desktop. Thinking I would be able to trick it, by just replacing


with the backup I’ve made. But ever since it’s doing that.
To summerize: the original config file is back in its original location. So technically there weren’t any changes. At least that’s what I feel like should be happening.

I knew there was something I was missing…
So if I edit the config files there, they should apply user-wide, right?
Hmm… wish I knew that sooner… :sweat_smile:
So just copy them there, edit and restart… If they break it’s going to use the fallback files I just broke I suppose…?

Another idea crossed my mind: Couldn’t I just uninstall pulseaudio and reinstall it?
In theory it would then use the default settings (the ones that it ships with) and should work like it used to…

I feel like every time I thought that, Linux proved me that this is, in fact, not how it works…
But I suppose I could give that a try as well…

Oh, one more questions: what’s the difference between

pulseaudio -k

and your command ?

My guess is that one applies only for the user and the other one for the root user… but then why would that be a thing…

Anyways, I hope I gave some piece of info that you can work with…
And if not, I could try to either restore the system via Timeshift or I’m just gonna back up my data and reinstall the OS. Without breaking it next time… hopefully… :wink:

Yeah you can, like this:

pamac reinstall manjaro-pulse --overwrite "/etc/*"

The overwrite parameter says here: overwrite everything what matches the /etc path at the package.

No… pulseaudio is managed by systemd on Manjaro and is not daemonized. Therefore, if you run pulseaudio yourself daemonized (and distros did that before systemd) then the kill command should do its job.

On a system managed by systemd, please use its utilities.

About the read locations of the configs, you can type for example:

man pulse-daemon.conf 
man default.pa

There you see the read priorities of the configs.

To be honest, that is now beyond my sound knowledge. I am more a system administrator then a “sound guy”.

However, if it repeats, there is a loop on the sound route.

Sorry, it’s been a few days…

So, I decided to reinstall Pulse, simply because it was the easiest fix. And so far it’s working.

Your idea with the loop on the sound route makes the most obvious sense, but I don’t recall enabling any options for it or adding any lines to enable it to the files
But I think there should actually be an option to pass through a line input through the main output.
Maybe I’ve actually enabled such an option and just forgot about it because I would do that thinking it could be useful, even though I’d only use it like once every year or so…

Anyways, thank you for your time and help on the topic.

Note to self: Don’t mess with stuff I technically know nothing about but think I do… :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.