Pulseaudio, Alsa, Audacity and resampling

Hey Folks,

I’m using stable branch with xfce. I use my PC for mixed use, and was writing to see if someone could help me, or shed some light on a specific audio configuration.

My desire is to be able to use Pulseaudio without resampling audio, both when I record in Audacity and playback via my local files (via nfs) and Google Chrome. I want all playback to go through my USB connected DROP SDAC, and recording to be captured through the PCI soundcard on the motherboard, which I’ve confirmed supports the bit depth and sample rate I seek for recording.

Where I am at currently: I have configured Pulse audio at /etc/pulse/daemon.conf with default bit depth and sample rate to s24le and 96000 respectively. I have also set avoid-resampling = true and uncommented all of these. Problem is setting these at the same time is a conflict. Setting the default bit depth and sample rate will force resampling of all playback, from any source. Commenting out the custom bit depth and sample rate allows the avoid-resampling = true to work, and I get playback without resampling from pulse, but am unable to have two applications open simultaneously with different bit depths. As an example, if I listen to 32/96k in audacious output to pulse, then listen to a Youtube video with audacious paused, Pulse will upsample the Youtube Video to 32/96k. It can only handle one bit depth/sample rate at a time, to my knowledge.

I could leave the custom bit depth and sample rate in Pulse if I could use ALSA directly for playback for local files and Google Chrome. At time of writing, I’ve succesfully configured Audacious to output natively to ALSA, but not found a method to direct audio from Google Chrome (for AUR) at ALSA directly.

In conclusion I am currently left with the following:

To listen to the native bit depth/sample rate audio from my local files, I use Audacious output to ALSA with the SDAC output configured to OFF in Pulse Volume Control.

To listen to native audio from the web/Spotify I have to change the setting in Pulse Volume Control for the SDAC from off to Analog Stereo.

To record at full fidelity in Audacity, I simply uncomment the custom bit depth and sample rate (s24le/96000) in /etc/pulse/daemon.conf and then pulseaudio -k . When I’m done recording I have to recomment those lines, and pulseaudio -k.

Any insight or recommendations would be appreciated,


After some testing, was able to satisfy my needs.

/etc/pulse/daemon.conf needs to be edited with

alternate sample rate = 96000

and Pulse Volume manager configured for my internal soundcard as stereo input only, and my external dac as stereo output only.

Once that was done, and Audacity was configured to use ALSA in it’s settings, I was able to record and playback at the correct 32/96khz.

As well as playback my audio files, both local and streaming at their correct bit depth and sample rate.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.