Puddletag failed to build

Hi, folks…
I’m not a new user, really, having used Manjaro a couple times. I got tired of distro-hopping finally, and came back here. I’m currently using Manjaro 20 with the Budgie desktop.

Problem: I tried to install Puddletag from the AUR, but the build fails because of a problem with phonon-qt4, namely an untrusted gpg signature. Here’s the output from Add/remove Software (I’m using the GUI for now):

Cloning puddletag build files...
Checking puddletag dependencies...
Cloning pyqt4 build files...
Checking python2-pyqt4 dependencies...
Cloning python2-musicbrainz2 build files...
Checking python2-musicbrainz2 dependencies...
Cloning python2-configobj build files...
Checking python2-configobj dependencies...
Cloning python2-mutagen build files...
Checking python2-mutagen dependencies...
Cloning phonon-qt4 build files...
Checking phonon-qt4 dependencies...
Cloning python-sip-pyqt4 build files...
Checking python2-sip-pyqt4 dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building phonon-qt4...
==> Making package: phonon-qt4 4.10.3-1 (Fri 28 Aug 2020 04:03:12 AM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found phonon-4.10.3.tar.xz
  -> Found phonon-4.10.3.tar.xz.sig
==> Validating source files with sha256sums...
    phonon-4.10.3.tar.xz ... Passed
    phonon-4.10.3.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
    phonon-4.10.3.tar.xz ... FAILED (unknown public key B92A5F04EC949121)
==> ERROR: One or more PGP signatures could not be verified!
Failed to build phonon-qt4

Here’s inxi output:

  Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=513dd560-e6e4-4d50-81aa-68a3a0293437 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Console: N/A wm: budgie-wm DM: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Hewlett-Packard product: 700-414 v: 1.00 
  serial: <filter> Chassis: type: 3 serial: N/A 
  Mobo: Hewlett-Packard model: 2AF7 v: 1.04 serial: <filter> UEFI: AMI 
  v: 80.20 date: 10/31/2014 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M525 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: Quad Core model: Intel Core i5-4570 socket: BGA1155 bits: 64 
  type: MCP arch: Haswell family: 6 model-id: 3C (60) stepping: 3 
  microcode: 28 L1 cache: 256 KiB L2 cache: 6144 KiB L3 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25554 
  Speed: 3392 MHz min/max: 800/3600 MHz base/boost: 3200/3200 volts: 1.2 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 3392 2: 3392 3: 3392 4: 3392 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0412 
  Device-2: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 01:00.0 
  chip ID: 1002:67ef 
  Display: server: X.org 1.20.8 compositor: budgie-wm driver: amdgpu,ati,intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.37.0 
  5.7.15-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aae0 
  Sound Server: ALSA v: k5.7.15-1-MANJARO 
  Device-1: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: bcma-pci-bridge v: N/A modules: bcma port: e000 
  bus ID: 03:00.0 chip ID: 14e4:43a0 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Local Storage: total: 2.90 TiB used: 23.74 GiB (0.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: HP51 scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
  ID-3: /dev/sdc vendor: TeamGroup model: T253X2128G size: 119.24 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 61C3 scheme: GPT 
  ID-4: /dev/sdd type: USB vendor: SanDisk model: Ultra size: 57.28 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
  scheme: MBR 
  ID-1: / raw size: 59.37 GiB size: 58.19 GiB (98.01%) used: 23.74 GiB (40.8%) 
  fs: ext4 block size: 4096 B dev: /dev/sdc3 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 69.0 C mobo: N/A gpu: amdgpu temp: 29 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1442 
  Processes: 260 Uptime: 1h 09m Memory: 11.61 GiB used: 4.24 GiB (36.5%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: 1454 pacman: 1443 
  lib: 401 snap: 11 Shell: Bash (sudo) v: 5.0.18 running in: gnome-terminal 
  inxi: 3.1.05 

After searching this forum, I tried to import the key referred to above in the text output from the Add Software app, but that failed also, with the message:

gpg: keyserver receive failed: General error

I also tried to specify the keyserver, but that failed, too, with the same error.

Is there any way to fix this, or do I just have to wait?

Thanks for any help!

You need to import the key in question.

Install puddletag-git instead, it uses Qt5 and Python 3.

Thank you! I’ll give that a try right now.

(Sorry for the delay in responding. Work has been crazy, and looking at a computer was the last thing on my mind.)


I actually tried that, but got a message that the key was untrusted, then another error that the key was unknown.


Just so you know, the stable version has been updated now as well.

Following up, puddletag-git installed just fine.

Thank you!


Cool! Is there enough of a difference between that and the git version to make installing it worthwhile?


Well, it depends if you want a stable or development version installed.

Okay. I’ll stick with the development version for now, I suppose. I can always install the stable version later, if necessary.

Thank you for all the help!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.