PS5 DualSense Controller causing programs to hang and crash if connected via Bluetooth

I recently bought a duelsense controller after seeing you can use the touch-pad as a mouse on Linux.
However, whenever i connect the controller via Bluetooth a number of programs will hang and fail to start.

Observed Programs Effected

  • Steam
  • Firefox
  • Discord
  • Pamac
    and probably more

if i run dmesg immediately after the controller is connected there doesn’t seem to be anything out of order in the log and the controller seems to be connected properly. Once i try to launch any of the listed programs dmesg also fails to run and hangs.

As alluded to, if the controller is connected via USB everything works fine.

I’ve seen similar reports lately. Not sure what the cause is yet.

There was another post that had a very similar report, but I can’t find it now.

Ive just done a fresh install of Manjaro Gnome 21.2.0 and the problem persists in the live version of Manjaro on the USB and in the fresh install.

I connected the controller to my laptop (Thinkpad x13 gen 1 AMD) and everything worked correctly with no issues so im thinking this might be a driver issue with my network card.

For reference the network card im using for WiFi and bluetooth is a Gigabyte WBAX200 WiFi 6 AX200 Wireless PCIe Adapter.

I might try a live copy of a different distro to see if this is something specific to manjaro.

Ive found that its mainly steam that’s causing the issue, I can launch firefox and steam now but once i try to launch steam everything hangs.

Thanks for your help anyway