PS3 gamepad sending wrong axis value

PS3 Controller is sending wrong info to half of my wine games, and this is due to the axis wrong position. So, in certain games the controller sends a left or a up message, so the menus are impossible to navigate and the camera, obviously, just spins around.

Things I noticed and tried:

  • Different wine versions give different results. So for some games, the glorious eggroll 5.9 fixes the issue. For other games, it doesn’t;
  • I reinstalled the whole OS from scratch with a different desktop env (I’m now on KDE). The problem persisted with the same games;
  • I ran the command jstest /dev/input/js1 and noticed that the L and R triggers have a value of -32767 on idle, so I guess this might be the problem? I have no clue on how to edit the gamepad configurations… I can’t find this directory /dev/input, I think I’m missing something here but the Arch Wiki is just all over the place and I’m bad at it.

I wish there was a way to override the default config for certain games. But really the best would be to fix this by default… I have this problem for months and it’s kind of infuriating because these games worked great before and all of a sudden started to make my gaming life kind of miserable, and reinstalling the whole OS didn’t pay off at all.

Thanks for any help!

Is it not possible to calibrate it using System Settings → Input Devices → Game Controller? I don’t have a controller or joystick with me at present but can post a screenshot of the settings window later when I connect one, if you want.

I assume you’ve tried that, though.

By the way, welcome to the Forum! :smile_cat:

Yes I did try different configs, but the triggers keep being triggered by default :frowning: Even if now the R-L triggers are at 0 on iddle, the game just acts like I’m pressing them.

Thanks! I like your profile pic :slight_smile:

1 Like