PS3 controller not being detected properly

I bought two new PS3 controllers and both of them are being detected as Xbox controllers. One of them is an official Sony controller and the other is a cheap knockoff.
When I plug them in through the USB cable the first and fourth lights are solid and none of the buttons or sticks will show an input in the system settings.

mhwd -lh -d --usb result:

17: USB 00.0: 0000 Unclassified device
SysFS ID: /devices/pci0000:00/0000:00:02.1/0000:05:00.0/0000:06:0c.0/0000:0c:00.0/usb1/1-1/1-1.1/1-1.1.3/1-1.1.3:1.0
SysFS BusID: 1-1.1.3:1.0
Hardware Class: unknown
Model: “Microsoft Xbox360 Controller”
Hotplug: USB
Vendor: usb 0x045e “Microsoft Corp.”
Device: usb 0x028e “Xbox360 Controller”
Revision: “5.72”
Serial ID: “000000000001”
Driver: “xpad”
Driver Modules: “xpad”
Device File: /dev/input/js0
Device Files: /dev/input/js0, /dev/input/by-path/pci-0000:0c:00.0-usb-0:1.1.3:1.0-joystick, /dev/input/by-id/usb-Nintendo_Co.__Ltd._XBOX_360_For_Windows_000000000001-joystick
Device Number: char 13:0
Speed: 12 Mbps
Module Alias: “usb:v045Ep028Ed0572dcFFdscFFdpFFicFFisc5Dip01in00”
Driver Info #0:
Driver Status: xpad is active
Driver Activation Cmd: “modprobe xpad”
Attached to: #12 (Hub)

I also tried plugging them into an old laptop that dual boots Windows and Ubuntu had the same problem but they worked in Windows.

Maybe some good info here Gamepad - ArchWiki

The vendor ID of your controller seems to indeed be the one for Microsoft USB\VID_045E = Microsoft Corporation - USB ID Database - Vendor ID and Product ID list - the sz development

What if you reboot, and plug only the “real” controller. Still same issue? I have doubt they are legit ones, if their vendor ID is indeed the Microsoft one.

//EDIT: SONY Vendor ID is 054C so I have doubts about your “legit” controller from SONY with a MS Vendor ID.

I have bluez, bluez-utils and bluez-plugins installed but that shouldn’t matter because I’m trying to pair it with USB. The cheap controller has a model number of CECHZC2U and has Bluetooth and DualShock III on the back so it should pair like a PlayStation 3 controller.
But when I plug it in and press the start button the first and fourth lights light up instead of only one.
The other controller is branded Sony® Sony Computer Entertainment Inc and has a model number of CECHZC2U. It also has Dualshock III and Sixaxis on the front of it so it should pare like a PlayStation 3/4 controller.
But when I plug it in and press the start button the first and fourth lights light up instead of only one.

In section 5 the only thing that might apply to me would be 5.8 but I’m trying to get it to work through USB first. Also ds4drv conflicts with blues-utils and is an AUR package so it will probably break more stuff than it fixes.
I tried to find out what the first and fourth lights being on meant but couldn’t find anything. I also downloaded the official tool from Sony to update the firmware on the controller but it didn’t help.

Then why does it give a Vendor ID from Microsoft, that makes no sense to me. Something is wrong here.


So? What information is it giving with only the “official” SONY controller, after a reboot?


Try with other LTS kernel too.

Some fakes look very close, including the CECHZC2U model number.

I plugged the controller in and reset my computer and lsusb shows
Bus 001 Device 006: ID 045e:028e Microsoft Corp. Xbox360 Controller

I also did the same thing on my laptop with Ubuntu 22.04 and lsusb shows
Bus 001 Device 002: ID 045e:028e Microsoft Corp. Xbox360 Controller

Problem is the same on Manjaro with 6.1.41 and 6.4.6-1 and Ubuntu is on 5.15.

Pretty sure you got fake controllerS then. They present themselves as “legit” Xbox controllers, probably because they are basic Direct Input controllers simulating an Xbox controller. You got scammed.

Probably you could get them to work but at this point I would just say good luck in your investigation.

Here is a starting point: linux fake ps3 controller - Google Suche and maybe Fake PS3 controller fix & udev rule · GitHub