ProtonVPN GUI & CLI connection error

Hi all
I’m not new to protonvpn errors but this one is new!!?

org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/15”

I’ve tried using the GUI and CLI with the same result? My system hasn’t changed (never does) and everything else is working fine (portmaster, firewall etc)

Any ideas??

I hope you don’t mean that on a rolling release distribution :slight_smile:
The last update on 11th August had a lot of changes in python packages. Since Proton is an AUR package, have you rebuild it after the update?

By installed yesterday, I meant the whole os [sorry, should have made that clear)

Ok then it is something else then, i have no idea. Here are some tips but they seem pretty basic.

Thanks buddy, Those were the first things I tried. I used protonvpn kill switch once in Mint 20 and it completely killed my connection (as in had to completely remove protonvpn & reinstall the network drivers). ProtonVPN kill switch is notoriously dodgy!!