ProtonVPN doesnt work in specific network

The protonvpn client normally does work with my home wifi.

As soon as I try to connect with the wifi in my school (to bypass the blocked websites and contents) the vpn gives out an error and doesn’t connect.

Earlier I used Windows 11 on my Laptop, in this case the vpn worked perfectly fine for both wifies.

How do I make the client work for my linux environment?

When asking for technical support, never say “I got an error”. Always include the error that you get.

1 Like

As soon as I’m going to connect with the wifi again I will mention the specific error message.

For now I just can say that the connection fails and the error says something like “connection cancelled” or “failed”.

Well it’s kind of difficult to help without the specific error message. My preliminary guess is that your school has blocked connections to Proton VPN’s servers, in which case you are SOL.

But why is proton working on windows and mobile then?

Oh sorry I misread your post. Anyway, get back to us with an error message and we can move forward on this.

The error message is “Unknown reason occured.”

Can you perform a reboot, try again right after you boot up, and then paste the output of the below command?

journalctl | grep proton

If you’re a paying customer for Proton VPN, then this seems like something you should contact them about, since it’s their software, they should have a better idea of why you get this error.

Apr 17 09:25:19 KeineShow python[6802]: INFO:protonvpn-daemon-logger:
Apr 17 09:25:19 KeineShow python[6802]: Virtual device being monitored: proton0; Attempt 2/100 with interval of 5000 ms;
Apr 17 09:25:19 KeineShow python[6802]: INFO:dbus-wrapper:Get connection interface from ‘proton0’ virtual device.
Apr 17 09:25:19 KeineShow python[6802]: ERROR:dbus-wrapper:[!] Could not find interface belonging to ‘proton0’.
Apr 17 09:25:19 KeineShow python[6802]: INFO:protonvpn-daemon-logger:VPN interface: None
Apr 17 09:25:19 KeineShow python[6802]: INFO:protonvpn-daemon-logger:Active connection: /org/freedesktop/NetworkManager/ActiveConnection/2

This output repeats itself for a bunch of seconds.

I am using protonvpn on Manjaro and there is no issues with the client

If you use the terminal client (you may not need this - if the stored credentials exist)

protonvpn-cli login <your-username>

Use the TUI to locate a server you have access and connect

protonvpn-cli connect

Or connect directly to a specific server - as this may provide some additional information

protonvpn-cli connect nl-free#158001

Still doesn’t work for me it seems that it just times out after trying for 20 seconds.

edit: Since it seems to work on other peoples manjaro and its working on my machine with windows installed i think it might be some kind of network blocker.

I cannot guess what your issue is - I know one thing though - there is nothing with a default Manjaro installation which implements any kind of blocking or filtering.

Setting up firewall and filters for allowing or blocking traffic is not a responsibility of Manjaro - though some has an opinion that a firewall should be enabled - but for what I know it is the end user which need to implement such measures.

 $ protonvpn-cli connect dk#14
Setting up Proton VPN.
Connecting to Proton VPN on DK#14 with UDP.

Successfully connected to Proton VPN.

Have you been experimenting with portmaster or opensnitch?