Proton Unity games freezing system

I’ve seen others have similar issues before but never got a conclusion to what happened, so I’m here for help now.

I’ve been having this issue for about 3 weeks now, and it had never happened before that point. After launching a game on steam, I’m able to play it for between 30 seconds to a handful of minutes, but it eventually freezes my entire system, only leaving the audio playing. Nothing is responsive, so I’m forced to force-shutdown.
inxi output:

  Host: sprig-rogstrix Kernel: 5.16.2-1-MANJARO x86_64 bits: 64
    Desktop: LXDE 0.10.1 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G531GT_G531GT v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G531GT v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: G531GT.308 date: 02/01/2021
  ID-1: BAT0 charge: 37.3 Wh (100.0%) condition: 37.3/50.5 Wh (73.7%)
    volts: 12.5 min: 12.5
  Info: 6-core model: Intel Core i7-9750H bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 4036 min/max: 800/4500 cores: 1: 4097 2: 4087 3: 4041
    4: 4093 5: 4081 6: 4064 7: 4003 8: 3772 9: 4061 10: 4009 11: 4095 12: 4029
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
    v: 495.46
  Display: x11 server: X.Org driver: loaded: modesetting,nvidia
    unloaded: nouveau resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.4
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Device-2: NVIDIA driver: snd_hda_intel
  Device-3: Audio-Technica AT2020USB+ type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
  IF: wlo1 state: up 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno2 state: down 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 484.39 GiB used: 230.63 GiB (47.6%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
  ID-2: /dev/sda type: USB vendor: Lexar model: USB Flash Drive
    size: 7.46 GiB
  ID-1: / size: 468.09 GiB used: 230.63 GiB (49.3%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 95.0 C pch: 61.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 4800
  Processes: 298 Uptime: 5h 57m Memory: 7.61 GiB used: 4.33 GiB (56.9%)
  Shell: Bash inxi: 3.3.12

As the title says, from my testing it seems like only Unity games are having this issue. Other games, no matter how intensive on resources, run with no freezes. The freeze also seems to only happen when tabbed into a game. It can be open in the background and not freeze, but as soon as I tab in it freezes and I have to shutdown. Around the same time I started getting this issue was when I switched from XFCE to LXDE. I don’t know how that would affect running Unity games, but it happened so close I figured I’d mention it.

this is a little hot …

oh hot dang, never noticed that. I only every focused on GPU temps, but I guess I was wrong. The next issue is that every fan software that I’ve tried has not recognized my fans at all, so I’m not sure where to go for solving this. For the record, I’ve tried Fan Control, Fan Control GUI, fanctl, and asusctl, and none of them recognized my fans. Any other programs to recommend?