Proton games freeze system when ping spikes

I’m mainly playing Battlefield 4 and Rocket League. And in both games I noticed the following scenario: When I’m only using Wi fi, both games will freeze for around 3 to 5 seconds quite often, although otherwise they perform seamlessly. The strange bit here is that this does not happen when using a cabled connection. Native games don’t seem affected by any of this

My first thought was, since I’d expect some lag spikes when playing though wi-fi, that for some reason wine/proton isn’t handling lag spikes quite well and freezes the system. I’ve then tried to use other proton versions (ge and vanilla), graphics drivers, and even installed the current lts kernel. None of these made a difference

Is there anything I’m missing here? Other distros I’ve tried didn’t had this problem (when a lag spike occured, the game lagged as it should, didn’t drag the system along), though I am yet to understand if this is problem is distro specific or not. If anybody had an issue similar to this please let me know. Thanks in advance

Here is my system info (inxi -Fxznc0) , in case it helps:

Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: Cinnamon 4.6.7 Distro: Manjaro Linux
Type: Laptop System: ASUSTeK product: X541UV v: 1.0 serial:
Mobo: ASUSTeK model: X541UV v: 1.0 serial:
UEFI: American Megatrends v: X541UV.305 date: 10/16/2017
ID-1: BAT0 charge: 26.9 Wh condition: 28.7/34.6 Wh (83%)
model: ASUSTeK ASUS Battery status: Charging
Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP
arch: Skylake rev: 3 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx  
bogomips: 20810
Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500
3: 500 4: 500
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915
v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM108M [GeForce 920MX] vendor: ASUSTeK driver: nvidia
v: 450.66 bus ID: 01:00.0
Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
bus ID: 1-6:2
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
resolution: 1366x768~60Hz
OpenGL: renderer: GeForce 920MX/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66
direct render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK 
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k5.4.64-1-MANJARO
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
driver: r8169 v: kernel port: d000 bus ID: 02:00.2
IF: enp2s0f2 state: up speed: 100 Mbps duplex: full mac:
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On
driver: rtl8723be v: kernel port: c000 bus ID: 03:00.0
IF: wlp3s0 state: up mac:
Local Storage: total: 232.89 GiB used: 170.82 GiB (73.4%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB   
ID-1: / size: 211.61 GiB used: 170.82 GiB (80.7%) fs: ext4 dev: /dev/sda2
ID-1: swap-1 type: partition size: 16.58 GiB used: 0 KiB (0.0%)
dev: /dev/sda3
System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 36 C
Fan Speeds (RPM): cpu: 2200
Processes: 204 Uptime: 29m Memory: 15.08 GiB used: 2.06 GiB (13.7%)
Init: systemd Compilers: gcc: 10.2.0 Packages: 1350 Shell: Bash v: 5.0.18
inxi: 3.1.05

Wot Blitz is also unplayable with basic settings.

But, they helped

network only add blacklog

if it exists, then mouse driver (ie: ckb-next)

That happens a lot on Cheap! :tm: Crap! :tm: Inc! :tm: routers as their CPU (which handles the WiFi) cannot cope with the required bandwidth whereas the cabled connection has a hardware switch that doesn’t have this issue.


  1. Change your router to a good brand with good performance (I.E. not Tp-Link or LinkSys) and pay at least 100$ for it and look for “High bandwidth WiFi”). I like AVM and am replacing all of my family’s routers with that brand.
  2. Use a cable


I have the exact same problem using a Realtek WIFI in my HP PC.

Ping time rises from 12 s to 3500 s every 40-50 seconds or so.

Other devices e.g. iPhone, laptop do not have ping problem.

Therefore I think you are wrong supposing that the router is the problem here…

Can you think of sth. else?

An RTL810xE on a 5.4.64-1-MANJARO kernel as well???

if not, please read the forum rules and open a new topic and provide the minimal information needed for us to help you…