Proton-cli login error (maybe caused by kdewallet)

Hey, I tried to run proton-cli login and I got promped with KDE wallet, and everytime it appears in all programs, even internet it gives a error and, it was no different with proton-cli, so I can’t login.

protonvpn-cli login pablocavalo666                                                             1 ✘  11s  
Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/keyring/", line 21, in __getitem__
    stored_data = self.__keyring_backend.get_password(
  File "/usr/lib/python3.11/site-packages/keyring/backends/", line 78, in get_password
    collection = self.get_preferred_collection()
  File "/usr/lib/python3.11/site-packages/keyring/backends/", line 67, in get_preferred_collection
    raise KeyringLocked("Failed to unlock the collection!")
keyring.errors.KeyringLocked: Failed to unlock the collection!

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/protonvpn-cli", line 33, in <module>
    sys.exit(load_entry_point('protonvpn-cli==3.13.0', 'console_scripts', 'protonvpn-cli')())
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 21, in main
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 65, in __init__
    res = getattr(self, args.command)()
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 162, in login
    return self.cli_wrapper.login(args.username)
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 63, in login
    if self.protonvpn.check_session_exists():
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/", line 356, in check_session_exists
    return self._env.api_session.is_valid
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/", line 56, in api_session
    self.__api_session = APISession()
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 264, in __init__
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 293, in __keyring_load_session
    keyring_data_user = ExecutionEnvironment().keyring[
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/keyring/", line 32, in __getitem__
    raise exceptions.KeyringError(e)
protonvpn_nm_lib.exceptions.KeyringError: Failed to unlock the collection!

Make sure NetworkManager.service is running.

There is this part in the manual:

3. Manually install the PGP key in ArchLinux / Manjaro

If your package manager fails to fetch or import the key, you can import it manually using the steps below. Please note that we use Pacman for this (not Pamac, as used in the main setup guide above).

a. Download our public PGP key

Click the link to download.

b. Add the key to Pacman

In Terminal enter:

pacman-key --add /path/to/downloaded/public_key.asc

(Replace /path/to/ with the path to wherever you downloaded key)

c. Ensure that the key has been added to pacman keyring


pacman-key --finger 6A5571928D2222D83BC7456E4EDE055B645F044F

d. Sign the key


pacman-key --lsign-key 6A5571928D2222D83BC7456E4EDE055B645F044F

Might be worth trying? How to use the v3 ProtonVPN Linux CLI

i try to stay away from KDE wallet because the moment it kicks in,it becomes an annoyance not easy to disable.
as for Protonvpn; i think it’s asking for the IKEv2 key(secret) that you can find on on your VPN page. at least that’s what i get.(and KDE wallet is disabled in my system).

Our Linux CLI needs one of the following dependencies installed in order to work. Installing both of these dependencies is not recommended as it may cause problems:

  • KWallet or
  • Gnome-keyring

Note that most distros come pre-installed with one of these dependencies, so usually no additional configuration is required. Also required is:

  • systemd

It worked, thanks. :slight_smile:

It happened again, bu this time isn’t fixing, idk why

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.