Proprietary Drivers - Changes failed

I’m trying to switch to proprietary drivers though the Manjaro Settings Manager, but I keep getting the error below. I was running the 5.8 kernel, but I downgraded to 5.7 and it is still not working. The system is fully updated.


Using config ‘video-nvidia-450xx’ for device: 0000:08:00.0 (0300:10de:2187) Display controller nVidia Corporation TU116 [GeForce GTX 1650 SUPER]
Installing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux57-nvidia-440xx breaks dependency ‘linux57-nvidia-440xx’ required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!

Done …

You need to remove those packages
sudo pacman -Rns linux-latest linux-latest-nvidia-440xx

1 Like

You need to execute in a terminal:

sudo pacman -R linux-latest-nvidia-440xx
sudo mhwd -i pci video-modesetting
sudo mhwd -r pci linux57-nvidia-440xx 
sudo mhwd -i pci linux57-nvidia-450xx 
1 Like

This worked. Thanks a ton!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.