Programs are taking longer to open. Steam takes more than 5 minutes


I installed Manjaro Gnome in May of this year and recently(past few weeks) it seems to be slower to open most programs.

I have no idea how to troubleshoot what is happening, and I fear I am making things worse.

I hope someone points me to the right direction on figuring out those problems. Worst case scenario I will have to install the SO again.

Thank you very much!


Most programs are taking less than 1 minute to open, but they used to be almost instantaneous.
And they act kind of weird, for example the terminal: it “opens” fast, but it takes a while to show the “fish” welcome message and to allow me to type.

The worst program seems to be Steam, it takes 5~10 minutes to open. I tried to follow the troubleshoot for AUR, and stuff I found here in the forum like:

  • steam-runtime --reset

  • deleting steam cache

  • disabling hardware acceleration.

  • removing everything than installing different packages

But nothing works and now I get a bunch of new messages when opening steam

  • Pins potentially out-of-date.
  • Forcing building of pins

And it also forgets my user.

When I try to run steam, top shows:

  • 90% ~ 94% idle
  • steam uses ~100MB of memory, 0% CPU and write ~15MB to disk.
  • the only changes in usage are:
    • if I alt+tab +10% usage of CPU.
    • if I resize terminal xorg and gnome-shell go crazy

The computer has 32GB of RAM, CPU AMD Ryzen 2700
Storage is in either a nvme or sata ssd.

In 1TB nvme:

  • SWAP 34GB
  • /boot 524 MB ext4
  • /boot/efi 524MB fat
  • / 419GB ext4
  • /home 569BG btrfs

I tried kernels 5.7.19 , 5.8.18 and 5.9.

inxi -Fxza --no-host

  Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: ro root=/dev/nvme1n1p4  initrd=\initramfs-5.9-x86_64.img 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.1 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: X470 AORUS GAMING 7 WIFI v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: X470 AORUS GAMING 7 WIFI-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F31 date: 05/06/2019 
  Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 118438 
  Speed: 1891 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 
  1: 1889 2: 1890 3: 2195 4: 2192 5: 2071 6: 2077 7: 4358 8: 2075 9: 2048 
  10: 1891 11: 1934 12: 1937 13: 4350 14: 1934 15: 2194 16: 2058 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ZOTAC 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 0a:00.0 
  chip ID: 10de:1e07 
  Display: x11 server: 1.20.9 compositor: gnome-shell driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: NVIDIA TU102 High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.1 chip ID: 10de:10f7 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 0c:00.3 chip ID: 1022:1457 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-9:4 chip ID: 046d:082d 
  serial: <filter> 
  Sound Server: ALSA v: k5.9.8-2-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb 
  v: kernel port: f000 bus ID: 06:00.0 chip ID: 8086:1539 
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: f000 
  bus ID: 07:00.0 chip ID: 8086:2526 
  IF: wlp7s0 state: down mac: <filter> 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 1-2:2 chip ID: 8087:0025 
  Local Storage: total: 6.12 TiB used: 1.07 TiB (17.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Seagate model: XPG GAMMIX S11 Pro 
  size: 1.86 TiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 42A4SANA scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: HP model: SSD EX920 1TB size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: SVN139B scheme: GPT 
  ID-3: /dev/sda vendor: A-Data model: SU800 size: 1.86 TiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: S86B 
  scheme: GPT 
  ID-4: /dev/sdb vendor: Plextor model: PX-128M6S size: 119.24 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1.03 scheme: GPT 
  ID-5: /dev/sdc vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 2B6Q scheme: GPT 
  ID-6: /dev/sdd vendor: Crucial model: CT480M500SSD1 size: 447.13 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: MU02 scheme: GPT 
  ID-1: / raw size: 390.62 GiB size: 383.99 GiB (98.30%) 
  used: 91.92 GiB (23.9%) fs: ext4 dev: /dev/nvme1n1p4 
  ID-2: /boot raw size: 500.0 MiB size: 476.2 MiB (95.24%) 
  used: 237.1 MiB (49.8%) fs: ext4 dev: /dev/nvme1n1p2 
  ID-3: /home raw size: 530.27 GiB size: 530.27 GiB (100.00%) 
  used: 89.63 GiB (16.9%) fs: btrfs dev: /dev/nvme1n1p5 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 32.00 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme1n1p1 
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 27 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
  Processes: 457 Uptime: 1h 42m Memory: 31.37 GiB used: 6.70 GiB (21.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 7/8/9 clang: 11.0.0 
  Packages: 1763 pacman: 1755 lib: 474 rpm: 0 flatpak: 4 snap: 4 Shell: fish 
  v: 3.1.2 running in: gnome-terminal inxi: 3.1.08 


Could you please disable the snapd service? sudo systemctl disable snapd

  • Snap has horrible performance , that’s all.

May also add your hostname into /etc/hosts by imploring sudo nano /etc/hosts, then adding something such as :     localhost.localdomain     localhost     YOURHOST                        YOURHOST

And of course replacing your hostname with yours…

After which you may run gdk-pixbuf-query-loaders --update-cache !

  • often, a broken icon database & cache may slow down the system !
1 Like

I would actually expect the latter using one of the fastest SSDs on the market.
Is trim enabled?

1 Like

Howdy @The_Quantum_Alpha

Thanks for the help!

It feels more responsive now. Terminal and Firefox are fast just like before.
There are just a few programs that are still slow. Vivaldi, Code and Steam are still taking a while to appear.
I might need to investigate them individually.

But everything else is as fast as it could be, and I tried even Manjaro Hello. :grin:

1 Like

Sweet! Glad I could help!:grin:
Have a wonderful day!

Hi @440Hz

Thank you for helping me.

fstrim.timer is not runing, but the drivers support it.
The brand is HP ex920. It is not the fastest but it was working fine.

sudo nvme id-ns /dev/nvme1n1

nlbaf   : 0
lbaf  0 : ms:0   lbads:9  rp:0 (in use)

lsblk --discard

nvme1n1            0      512B       2T         0
├─nvme1n1p1        0      512B       2T         0
├─nvme1n1p2        0      512B       2T         0
├─nvme1n1p3        0      512B       2T         0
├─nvme1n1p4        0      512B       2T         0
└─nvme1n1p5        0      512B       2T         0

It seems to support TRIM.

The fstrim.timer sevice is disabled.
running fstrim --fstab --verbose doesn’t seems to solve the issue. But I turned the service on just in case.

I am starting to think that those issues are individual from each program rather than the whole system.

As I tried both yours and The_Quantum_Alpha suggestions and Vivaldi, Code and Steam are still taking a while to open.

Ah, i thought you run manjaro on the XPG GAMMIX S11 Pro disk.

Anyway, i had issues with steam, too, yesterday. It took ages to load and switching to the store and browsing games was awfully slow. It’s all back to normal today, so the issue was remote.

I store the games on the XPG Gammix S11, mostly Steam, but Lutris and Gamehub as well.

I found a post from 2014 that helped me with steam Remove uninstall delete steam completely

It seems that the problem is with the game library, I wonder if it is the size ~800GB. I added a few games recently.

here are the steps:

First I ran
sudo pacman -Rns steam-manjaro

Deleted the folders and files


I kept the steam library folders, but I deleted a bunch of lost files and folders related to steam.

Then I installed steam again using
sudo pacman -Syu steam-manjaro

Steam opens the first time in 15 seconds. I log in and close. I open and close again a few times. Always 7~15 seconds.

I added the Steam Library, it froze steam for a while. Then I closed Steam. It took 11 minutes to open steam.

I will post this on their Github to ask for help. (Edit: they are aware of this problem Steam Client startup stalls when large number games installed. · Issue #7117 · ValveSoftware/steam-for-linux · GitHub and they have a workaround for it)

Vivaldi I use because I need chrome to access some of the tools from work, So it doesn’t matter that much if it takes a while to open.

Code is weird. I don’t have that many extensions on it. I will see what I can do about it.

1 Like

This can be a an filesystem issue.

First thing I spot is nvme - next thing is btrfs

If you have not enable fstrim.timer - your may be running out of unused blocks.

To fix this I suggest you run fstrim manually - then enable the fstrim.timer

sudo fstrim -a


sudo systemctl enable --now fstrim.timer

The next thing is btrfs - and I know absolutely nothing it that regard.

1 Like

Thanks for your help @linux-aarhus

I ran sudo fstrim -a -v . It did trim about 1TB across my storage devices. I tried fstrim --fstab --verbose before and it didn’t clean that much.

And for good measure I enabled fstrim.timer

Reading the logs it seems that last time I updated Manjaro, there where a problem that the video driver could create a config file.

depmod: ERROR: could not open directory /lib/modules/5.8.18-1-MANJARO: No such file or directory

It was weird because I am using kernel 5.9.

I found some similar problems on the forum and followed the fixing steps.

After trying the things suggested here I notice the system more responsive. But it seems that the worst of my problems are software specific. Like caches, paths missing, etc…

I am fixing one by one as I figure them out.