Problems with unbound and expat make my desktop buggy

Hey, I have followed an install guide from a github repo which didnt seem to work well with my machine, the instructions were:

sudo pacman -Sy --needed curl openssl libuv

sudo pacman -Syu --needed boost openssl zeromq libpgm libsodium libunwind xz readline gtest python3 ccache qt5-tools hidapi libusb protobuf systemd

tar -xf expat-2.4.8.tar.bz2
rm expat-2.4.8.tar.bz2
cd expat-2.4.8
./configure --enable-static --disable-shared
sudo make install
cd ../

tar -xzf unbound-1.16.1.tar.gz
rm unbound-1.16.1.tar.gz
cd unbound-1.16.1
./configure --disable-shared --enable-static --without-pyunbound --with-libevent=no --without-pythonmodule --disable-flto --with-pthreads --with-libunbound-only --with-pic
sudo make install
cd ../

My taskbar now is completely green, with no icons on it. The icons in my menu are not displayed anymore and files on my desktop dont have icons anymore either.

I am using KDE Manjaro, does someone have an idea how I can fix this?
Thanks in advance

uninstall what you installed - at least with your custom expat, you likely overwrote the expat library that was already installed - with a different version.

make uninstall
usually does the job

Both expat and unbound are easy to install from the normal repositories.
Install from there.

Both expat and unbound are in the official repository, why are you manually building older versions of them?

EDIT: Cross post on Reddit for reference:

Yeah this was my bad, I just copy pasted what was said in the setup guide

Hey, I’ve tried make uninstall and after sudo pacman -S the two packages but that didnt fix the problem

I’m sorry to hear that.
So, the problem perhaps was not caused by what you thought it was caused by.

Short of creating another user account and checking whether things work there as they should, I can’t suggest any way forward.

Never mind, the second restart seemed to have fixed it. Thanks a lot!

Ok update, I restarted it again and I get the same problem as before again.

see this my last reply …

Does anyone else have an idea?

I suggested to create another user account - to see whether things will work there.
Did you do that?
What was the result?

I think you messed up your KDE user configuration with the expat library. It is a dependency of 1859 packages, I’m surprised this “minor visual” issue is the only issue that occurs.

Have you force installed the official packages since then with pamac reinstall expat
(It should complain about existing files, so you can overwrite them with pamac reinstall --overwrite "*" expat).

Maybe the library is installed in /usr/local. Check if you have files there.