Problems with e-sword, wine?


I install e-sword 13 from the website and install wine, when I try to open it, it doesn’t work, so I go back to the page and follow the instructions, thi time for the package, Linux-12:

I removed e-sword-13, as far as i can see … (the command ‘locate’ do not work for me here).

install winetricks and run winetricks -q wmp11 (as it is recomended).

Everything seems to be fine … but it doesn’t download anything, the options to download, bibles, etc are frizzy, I guess I’m missing something to do in Manjaro, wine?.

Thanks for any advice.

Important note 1: GNU/Linux != Windows

Important note 2: Before going down the path of trying to install Windows software on a GNU/Linux machine via WINE, check the distro’s package manager (in the case of Manjaro, Pamac) to see if an alternative that works natively on Linux is available:

BibleTime is available from Manjaro’s extra repository & uses the Sword library. There are also other bible study apps available via the AUR.

1 Like

I know the application and it is missing some materials that I need, it is not an alternative for me, but thank you very much for recommending.

There isn’t much info on the web, and WineHQ - e-Sword doesn’t have any test results for recent versions of e-Sword, however this WineHQ forum thread may offer some help: eSword on Linux - WineHQ Forums

Perhaps Xiphos Bible Guide, which is suggested in the WineHQ forum thread & also on the WineHQ e-Sword page (Xiphos was formerly known as GnomeSword), and is available from the Manjaro repositories, might be a solution?

is another program.

Here are a few more - some of which may be for linux native or via Java

I did not find them - but I didn’t look for long.
Usually you download an executable and run it - update is just like the first time you install

That was likely not necessary - however you did that.

We don’t know how you did that.

That likely only prepares your wine prefix for the successful installation of the actual e-sword_1300_setup.exe

1 Like

I know it too, the same with xiphos …

[alnone@alnone-inspiron3583 ~]$ LANG=C locate wine
locate: can not stat () `/var/lib/mlocate/mlocate.db': No such file or directory
[alnone@alnone-inspiron3583 ~]$

*I tried wine-staging, nothing … and now i will try with wine-staging-git

locate relies on a database
this often gets created by a systemd timer or cron job
But you can initiate it manually:
sudo updatedb

I don’t know off the top of my head if this would also scan all of your $HOME directory.

wine is the program used to run Windows software - it’s system wide.
this will be found after the database is created/updated

Your bible program that needs wine to run is in your $HOME directory.
likely in ~/.wine - I don’t know how you installed it

When installing wine-staging the system warns to remove wine due to incompatibility, as it did not work, I went for wine-staging-git and right now it is compiling … about an hour ago … I will come back tomorrow, thanks for your indications.

Right–One can only have one installed at a time as they both provide the same thing. :wink:

Absolutely no reason to do that. Either way, you’ll encounter the same thing.

Well right now this just finished compiling the git version, and it works perfectly!

– it was a very extensive compilation, maybe that was the issue, more ‘worked’, I’m nobody to say this … but anyway… very happy.

Thank you all for your comments and advices,


I’m glad it’s working for you.


Indeed. You most likely wasted your time because you misunderstood what your package manager and myself just told you. Well, unless of course the bleeding edge wine-staging-git package fixes something. However, you don’t know if it does since from what you said, you haven’t even tried wine-staging yet.

:warning: Keep in mind you are the package maintainer of any AUR package you install. You should always use repo packages over AUR packages. As I’ve seen many times before, users will completely forget they installed an AUR package and wonder why things aren’t working after an update.

“as it did not work”

– Sorry, it is probably “my English”, I use Deepl or Google translator.

I meant it didn’t work (wine-staging)

*I understand about the risk of using packages outside of the recommended … but as long as the system does not offer them … what other alternative is there?.

EDIT: ‘sudo updatedb’, it works!. Thanks.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.