Problems with AMD CPU integrated graphics and nvidia GPU

System:
  Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=16b2b3a4-3d2d-4a9a-acbe-1fe4b14bc9ab rw quiet 
  cryptdevice=UUID=7dac0c1b-8747-400d-a776-086e1da77528:luks-7dac0c1b-8747-400d-a776-086e1da77528 
  root=/dev/mapper/luks-7dac0c1b-8747-400d-a776-086e1da77528 apparmor=1 
  security=apparmor 
  resume=/dev/mapper/luks-7442edda-8193-449d-b8b7-0fa374e07632 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505DT.308 date: 09/19/2019 
Battery:
  ID-1: BAT0 charge: 41.5 Wh condition: 42.6/48.1 Wh (89%) volts: 11.8/11.7 
  model: FX50442 type: Li-ion serial: N/A status: Discharging 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33550 
  Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1222 2: 1222 3: 1222 4: 1319 5: 1276 6: 1395 7: 1241 8: 1343 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:1f91 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 05:00.0 chip ID: 1002:15d8 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 3-1:2 chip ID: 13d3:56a2 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: amdgpu,modesetting,nouveau FAILED: ati alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.1-3-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 10de:10fa 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.1-3-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: c000 
  bus ID: 04:00.0 chip ID: 10ec:c822 
  IF: wlp4s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 9.99 GiB (4.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3256GJ3 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: E8FK11.T scheme: GPT 
Partition:
  ID-1: / raw size: 229.37 GiB size: 224.77 GiB (97.99%) used: 9.99 GiB (4.4%) 
  fs: ext4 dev: /dev/dm-0 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 38.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 38 C device: nouveau temp: N/A 
Info:
  Processes: 241 Uptime: 7m Memory: 15.51 GiB used: 1.39 GiB (9.0%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1217 lib: 344 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

I just switched to Manjaro KDE on my laptop and when I install the nvidia proprietary driver, my laptop won’t make it to the boot menu. I was able to fix this issue on Mint when I had it installed but I just can’t figure out how to fix it on Manjaro. Any help would be greatly appreciated!

can you please returns

sudo mhwd -li
sudo mhwd -l

Absolutely. Here you go:

Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

/

0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


> 0000:01:00.0 (0300:10de:1f91) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-amd-nvidia-450xx-prime            2019.10.25               false            PCI
video-hybrid-amd-nvidia-440xx-prime            2019.10.25               false            PCI
video-hybrid-amd-nvidia-435xx-prime            2019.10.25               false            PCI
    video-nvidia-450xx            2019.10.25               false            PCI
    video-nvidia-440xx            2019.10.25               false            PCI
    video-nvidia-435xx            2019.10.25               false            PCI
    video-nvidia-430xx            2019.10.25               false            PCI
    video-nvidia-418xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:05:00.0 (0300:1002:15d8) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-amd-nvidia-450xx-prime            2019.10.25               false            PCI
video-hybrid-amd-nvidia-440xx-prime            2019.10.25               false            PCI
video-hybrid-amd-nvidia-435xx-prime            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

then you should add

sudo mhwd -i pci video-hybrid-amd-nvidia-450xx-prime

and reboot

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'
# Nvidia render-offload alias
alias nvr="__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia"
alias vkr="__NV_PRIME_RENDER_OFFLOAD=1"

after you close/open terminal the alias for both will be set and then it’s

#opengl
nvr glxgears
#vulkan
vkr vkcube
1 Like

after running this i got:

invalid option: pci

Usage: mhwd [OPTIONS] <config(s)>

  --pci                                 list only pci devices and driver configs
  --usb                                 list only usb devices and driver configs
  -h/--help                             show help
  -v/--version                          show version of mhwd
  -f/--force                            force reinstallation
  -d/--detail                           show detailed info for -l/-li/-lh
  -l/--list                             list available configs for devices
  -la/--listall                         list all driver configs
  -li/--listinstalled                   list installed driver configs
  -lh/--listhardware                    list hardware information
  -i/--install <usb/pci> <config(s)>    install driver config(s)
  -ic/--installcustom <usb/pci> <path>  install custom config(s)
  -r/--remove <usb/pci> <config(s)>     remove driver config(s)
  -a/--auto <usb/pci> <free/nonfree> <classid>  auto install configs for classid
  --pmcachedir <path>                   set package manager cache path
  --pmconfig <path>                     set package manager config
  --pmroot <path>                       set package manager root

should i change pci in that command to --pci? sorry if i seem clueless, i just want to make sure i do everything properly as to not mess anything up.

ok so i’ve done everything up to this part. once i input either of these commands i just get :

bash: nvr: command not found

bash: vkr: command not found

add theses alias before

# Nvidia render-offload alias
alias nvr="__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia"
alias vkr="__NV_PRIME_RENDER_OFFLOAD=1"

ok so i got nvr glxgears to run but i’m getting this for vkr vkcube:

bash: vkcube: command not found

edit: sorry i pasted the wrong line originally

Hi!
the command to install the driver would be something like this
sudo mhwd -i pci driver

To add the alias lines you have two opcions

  1. Open the file .bashrc and add those lines at the end, save, and run
    source .basrc
  2. run this lines from the terminal
    echo " alias nvr="__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia" >> .bashrc "
    echo " alias vkr="__NV_PRIME_RENDER_OFFLOAD=1" >> .bashrc "
    then again
    source .bashrc

hey, i think this worked. it looks like my laptop is now using nvidia v 450.57 as its main driver. thank you and thanks to stephane for all the help. i truly appreciate it!