Problems with accents (tildes) in Manjaro

Hi! Since the instalation of Manjaro o nmy laptop ive been experiencing issues related to the correct writing of vowels with accent. Although they keyboard correctly writes all the keys in my keyboard, the accents go separate from the vowels as this:

´a e 'i ´o u

They do not mix with the vowel but they are separate from them. The language of my Manjaro XFCE is spanish, as my keyboard, and I do not know to correct this problem could you please help with this one.

I would Appreciate it.

Thanks!!

Are you using a modifier key i.e. in m case right ALT then e followed by ’ gives é …?

i’m having a related issue with my spanish keyboard, where pressing the keys on an english keyboard: [ + e gives è. here, the accent is in the wrong direction - this a french ‘accent grave,’ and is not used in Spanish.

the set-up i’m using is alternating between ‘en’ and ‘es’ keyboards, here’s what my 00-keyboard.conf file reads:

Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “us”
Option “XkbModel” “pc105”
Option “XkbOptions” “grp:alt_shift_toggle”
EndSection

any help appreciated!

@mcnugg3t Welcome to the Forum! :smiley:

On my (Englisk UK) keyboard, modifier + e + ' (same key as @) gives é. I assume this is what you want? (I set Right ALT as the modifier key).

1 Like

@BG405 thank you!

new convert from windows; i like it here!

yours looks like a good fix - will implement for now.

is there anyone to tell that the ‘es’ keyboard has this issue?

1 Like

note here for anyone else looking for a similar solution:

Manjaro XFCE, us 104-key keyboard

home -> settings manager -> keyboard -> layout

english -> edit -> (intl., with AltGr dead keys)

now right-Alt + a, e, i, o, u, n gives á, é, í, ó, ú, ñ

1 Like