Problems upgrading to Gnome 40

Hello, thanks in advance for your help! I have been using Manjaro for several months now, and so far it’s been an amazing experience. But then they decided to upgrade to Gnome 40… and all hell broke loose.

When I first logged in I couldn’t interact with anything at all. I realized that it had upgraded to Gnome 40, and that my PaperWM extension probably wasn’t compatible. So I disabled all of my extensions via the shell, rebooted, and got in just fine.

Here’s the problem… if I re-enable extensions in any way, shape, or form, everything breaks. The top bar becomes completely un-interactable, and trying to search for programs doesn’t work whatsoever. I have to reboot my PC, and when it comes back up, everything is immediately broken and the desktop is completely unusable.

This happens even when zero extensions are activated.

My first thought was to uninstall and reinstall all of my extensions and the extension manager. Unfortunately, I wasn’t able to upgrade linux-firmware during the large update due to a filesystem conflict. That means that I can’t reinstall the extensions app because it forces me to update linux-firmware, and that doesn’t work.

So I guess the first step is to figure that problem out and work from there. Maybe not updating linux-firmware is responsible for some of these problems. I’ve heard that doing partial updates can be really bad.

Welcome to the forum! :wave:

Please post the output.

You may find this helpful:


Thanks for the speedy reply! I actually meant to post the output in my original post, but forgot… sorry.

Here it is:


Running pacman -Qo /usr/lib/firmware/rtl_bt/rtl8761b_config.bin to find out which package owns it returns /usr/lib/firmware/rtl_bt/rtl8761b_config.bin is owned by rtl8761b-fw 20201202-1. Ordinarily I would follow the instructions and try removing that package, but it’s a firmware package so I don’t want to potentially make things worse by uninstalling it.

There’s no such package in the repos or AUR. Remove it and continue the upgrade. That firmware is now provided by the linux-firmware package, so what you had is now unnecessary.

Well… This is interesting. I booted my computer back up to do what you had suggested, and now my desktop is gone entirely. It just boots into the terminal. The desktop used to be on tty1 but it’s just… Gone. I tried all the function keys but none of them bring it up.

I went ahead and removed the old package, and upgraded linux-firmware via command line. It worked, but rebooting did not bring back the desktop.

I found a command that is supposed to start gnome (I think?), but running it yields an error.

I’m beginning to think that when I uninstalled the gnome extension manager, it might have uninstalled gnome entirely.

Update: I am 99% certain now that that is exactly what happened. When I uninstalled the extension manager it uninstalled absolutely everything to do with gnome. I remember seeing a bunch of things in the uninstall list but all the ones I saw were extensions so I didn’t scroll down much. Stupid me. This is definitely user error.

Extensions is not a separate package, it’s part of GNOME Shell itself. Try reinstalling gnome-shell.

Alright, I got gnome reinstalled. That was an adventure that I’ll be sure never to repeat again.

After doing this, I kept running into the original issue of everything breaking when I globally enable extensions, even if no extensions are actually enabled. I decided to simply remove all of my extensions. Upon doing this, the problem disappeared. I can enable extensions again and it appears to work so far.

I’ll get my setup more or less back to how it was, and if everything’s good, I’ll mark this as solved. I apologize for posting before I had tried all of the basic troubleshooting.

Alright, reinstalled everything, found some new extensions that are even better than what I had, and now everything is good! Sorry for troubling you. Gnome is silly sometimes.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.