Problems to reinstall grub on PC with dualboot W11/Manjaro KDE

Hello, I come here in search of some guidance, I was trying to repair grub after having formatted my Windows partition and installed Windows 11, since I lost access to Linux and grub4win does not detect it in principle. I ran the Manjaro chroot command from a live usb drive and it generated the following

==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
→ mount: [/mnt]
mount: /mnt: /dev/nvme0n1p5 already mounted on /mnt.
dmesg(1) may have more information after failed mount system call.
→ mount: [/mnt/boot/efi]
mount: /mnt/boot/efi: special device /dev/disk/by-uuid/B203-4C2B does not exist.
dmesg(1) may have more information after failed mount system call.
mount: /mnt/sys: sys already mounted on /sys.
dmesg(1) may have more information after failed mount system call.

I understand that it recognizes the partition but that it is missing others, how can it be solved?

you should check before CHROOT, partitions & UUID :

sudo parted -l
sudo lsblk -fs

Most likely windows has (or you have) deleted the EFI partition which was known by Manjaro and which contains boot files for Manjaro and also for Windows. You would need to reinstall grub in that case.

1 Like

…and for this reason better put the EFI of Manjaro on the Manjaro-system-disk.
And chainload Winndows. BIOS: Manjaro start as default.
If all systems are only on one Disk better ask Megavolt. :innocent:

Hi, I ran the commands you mention and it returned this

sudo parted -l

//Before write about the other disk and the flash drive, I omit it because it is not relevant

Model: WDC WDS500G2B0C-00PXH0 (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp, no_automount
 2      106MB   123MB  16,8MB               Microsoft reserved partition  msftres, no_automount
 3      123MB   370GB  370GB   ntfs         Basic data partition          msftdata
 4      370GB   371GB  720MB   ntfs                                       hidden, diag, no_automount
 5      371GB   500GB  129GB   ext4         root
NAME    FSTYPE FSVER LABEL          UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0   squash 4.0                                                             0   100% /run/miso/sfs/livefs
loop1   squash 4.0                                                             0   100% /run/miso/sfs/mhwdfs
loop2   squash 4.0                                                             0   100% /run/miso/sfs/desktopfs
loop3   squash 4.0                                                             0   100% /run/miso/sfs/rootfs
sda2    ntfs         Archivos       F48A5FA38A5F60E2                                    
sdb2    vfat   FAT16 VTOYEFI        BDAD-470D                                           
ventoy  iso966 Jolie MANJARO_KDE_2213
                                    2023-05-29-08-47-39-00                     0   100% /run/miso/bootmnt
└─sdb1  exfat  1.0   Ventoy         4E21-0000                                           
        vfat   FAT32                AE67-7754                                           
        ntfs                        98F66C84F66C648A                                    
        ntfs                        0AF881DDF881C781                                    
        ext4   1.0                  2c4fe4df-c53c-44a9-8820-722530ed4c11                

As far as I understand, nvme0n1p5 is the partition where Manjaro is installed.

Hi, yes, I have followed that guide, specifically I tried to install it with the manjaro-chroot method and what I published in the first post is the result of the command

manjaro-chroot -a

And as you see the UUID is different:

To avoid that in the future, create a second efi partition with gparted → 100MB, fat32, flag: boot,esp

Mount your root device and replace the old UUID in /etc/fstab with the newly created one. Save it and unmount.

Now run manjaro-chroot -a and it should mount the new efi partition also. Then you can reinstall grub as described in the wiki.

1 Like

check before UUID on /etc/fstab
UUID should be the same for /boot/efi and nvme0n1p1 ( AE67-7754 )
can you

manjaro-chroot -a 
cat /etc/fstab
    ~  manjaro-chroot -a                                                                                                                                       ✔ 
==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
mount: /mnt/boot/efi: special device /dev/disk/by-uuid/B203-4C2B does not exist.
       dmesg(1) may have more information after failed mount system call.
[manjaro /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=B203-4C2B                            /boot/efi      vfat    umask=0077 0 2
UUID=2c4fe4df-c53c-44a9-8820-722530ed4c11 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

UUID=B203-4C2B                            /boot/efi

They are different from what I understand, aren’t they?

imgur. com/a/WDsEulf

Something like that is what it should be, right? I cannot send images or links, sorry to send that in that form

A flag is not a label. Flag it with: Right click → Manage Flags → choose boot → Close


so 2 possibilities :
1 - correct on /etc/fstab UUID under chroot , ( nano /etc/fstab , Ctrl + X confirm changes )
also check ls /boot/efi/* , you will see manjaro and grub
exit and reboot

2 - if there no grub manjaro , you will have to reinstall grub under chroot in this case /boot/efi have to be mounted by chroot , so UUID have to be correct before chroot for restaure Grub

Great, I made the switch that you suggested with gpart, I was rereading the conversation for a while and I was able to go ahead and solve the problem, thanks!

After making the UUID change to the chroot file, it recognized the partitions, from there I followed the guide and no problem. I only had to do a few extra commands because Manjaro’s grub didn’t recognize Windows at first, but it wasn’t a big problem.

@stephane The solution was to reinstall grub con chroot, Can I then have to see the partitions to verify that there are no problems? I noticed that there was about 400mb of unallocated space.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.