Problems mounting Ventoy USB-stick

I spent a good few hours trying to troubleshoot why Dolphin refused to mount my usb-stick with Ventoy installed. Turned out that replacing the exfat-utils package with exfatprogs solved the problem.

Thought I’d mention this in case anyone has similar problems.

1 Like

I have recently also swapped out exfat-utils for exfatprogs, but I have never had any problems mounting my Ventoy USB stick with exfat-utils. So I doubt whether that would have been the cause.

I suspect that the problem may sit deeper than that, like for instance with the kernel you are using.

I haven’t had any problems either but it is a couple of weeks since I last tried mounting the stick and I suppose the kernel has been updated a couple of times since, I always run the latest kernel. The fact remains though, mounting the stick immediately worked after installing exfatprogs.

That may not be the wisest approach. :wink: You have to keep in mind that the latest kernel is always going to be bleeding-edge, and unless you’ve really got some equally bleeding-edge hardware, you’re probably going to be better off with an LTS kernel.

I’m running 6.1 LTS here, for that matter, and it’s a rock-solid stable kernel. :wink:

The main reason is I’m on BTRFS and I read somewhere that with BTRFS being a fast moving target it’s advised to keep up with the kernel updates. Don’t know how much truth it is to that, but so far it hasn’t been giving me any problems.

I’m using btrfs too. :wink:

Don’t believe all the scare-mongering. btrfs has been stable for well over a decade already. :wink:

1 Like

No doubt about that, it was more about getting the most out of it.

1 Like

1 Like