Problemas luego de instalar Manjaro XFCE

Hola comunidad!

Recien soy nuevo en linux, esta es la primera distribucion que instalo y estos son algunos de los problemas que tengo:

  • Lo primero es que si intento entrar a manjaro seleccionandolo en el boot aveces se me queda colgada una pantalla negra y no inicia nunca; sale el error failed to start, per si inicio sesion dejando correr el cronometro no tengo ningun problema. He encontrado como resolver el problema pero en intel y yo estoy utilizando AMD.

  • Otro problema que tengo es que cuando hago ciertas acciones esta presenta un pitido, sucede siempre que voy a la opcion de apagado, esto lo intente resolver y se soluciona mientras estoy en la sesion pero una vez que apago el computador y vuelvo a entrar el problema persiste, tal vez no se guardarlo bien permanentemente.

  • Tampoco puedo seleccionar cosas solo tocando el touchpad sino que tengo que presionar la parte izquierda obligatoriamente como si fuera un mouse.

  • Por ultimo en un momento deje la laptop encendida por un tiempo sin hacer nada y cuando quise volver a utilizarla el teclado no funciono tuve que reiniciarla, como podria arreglar esto?

Espero me puedan ayudar!

Hola @Gianfranco
Bienvenido al foro,
¿ podrías ejecutar en una terminal el comando inxi -Fazy y postearlo ?

Tal vez haya solución actualizando el grub, pero no estoy seguro.

Saludos

Hola Gracias por la respuesta, este es el resultado de ejecutar el comando:

System:
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=c4711a4f-fb06-45bd-97a7-2a583e7109d7 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5  
  serial: <filter> Chassis: type: 31 v: IdeaPad Flex 5 
  serial: <filter> 
  Mobo: LENOVO  v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVOv:  date: 04/08/2020 
Battery:
  ID-1: BAT0 charge: 39.6 Wh condition: 50.5/52.5 Wh (96%) volts: 12.3/11.5 
  model: Celxpert L19C3PD6 type: Li-poly serial: <filter> status: Discharging 
  cycles: 86 
CPU:
  Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 
  type: MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600102 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28454 
  Speed: 1397 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 04:00.0 
  chip ID: 1002:1636 
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 1-4:2 
  chip ID: 174f:243f serial: <filter> 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") 
  diag: 355mm (14") 
  OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
Audio:
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 04:00.1 
  chip ID: 1002:1637 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 04:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 2000 
  bus ID: 02:00.0 chip ID: 10ec:c822 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 7.96 GiB (3.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDHTNI-87A0B 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 11000C00 scheme: GPT 
Partition:
  ID-1: / raw size: 58.59 GiB size: 57.42 GiB (98.00%) used: 7.93 GiB (13.8%) 
  fs: ext4 dev: /dev/nvme0n1p5 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 40.5 C mobo: 38.0 C gpu: amdgpu temp: 39.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 221 Uptime: 1m Memory: 7.21 GiB used: 644.5 MiB (8.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1109 lib: 326 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08

Hola Gianfranco.

Es más eficaz presentar las dudas una por una en temas distintos, la lectura es más rápida y se hace más fácil afrontarlas.

  1. Revisa el log, desde una terminal:

    sudo cat /var/log/boot | grep -E ‘warn|err’
    sudo cat /var/log/syslog | grep -E ‘warn|err’
    journalctl -b

Comparta la solución para Intel a ver si puede extrapolarse.
¿Está instalado amd-ucode?

  1. ¿Se escucha un pitido en la opción de apagado?, ¿cómo lo solucionó inicialmente?

  2. Configure la opción de tocar para pulsar en las preferencias del panel táctil.

  3. ¿Cerró la tapa, suspendió o hibernó?

Configure la acción del cierre de la tapa y el tiempo de inactividad en las opciones de energía. La suspensión e hibernación siempre dieron problemas en Linux.

Si aún así el escritorio no maneja bien el cierre de la tapa, puede intentar anularlo desde una terminal:

sudo nano /etc/systemd/logind.conf
  HandleLidSwitch=ignore
1 Like

Hola @Gianfranco,
Buenas tardes, estoy de acuerdo con lo que dice @anon96648783.
Sin embargo, deseo preguntarte dos cosas:

  1. Tienes un disco de 240 Gb y utilizas 60 Gb para la partición / (root) en la instalación. Tienes algún otro sistema operativo instalado en tu notebook.
  2. En la sección Drives verás que te avisa que instales smartmontools, o bien, Gsmartcontrol que son herramientas que verifican la salud de tu disco rígido. Tal vez ese sea el problema.
  3. Además, no has cofigurado ninguna swap durante la instalación. A veces no es necesario, pero cuando suspendes la actividad cerrando la tapa necesitas memoria swap para guardar la sesión. Tendrías que ajustar la swap a 16 Gb, por lo menos.

Saludos, espero que sirva de algo.

1 Like