Problem with Wifi driver after updating

I used to use this driver GitHub - tomaspinho/rtl8821ce for my wireless chip, with this latest update I had to go back to rtw8821-ce (installed by default in the kernel, and which often gave me problems) because right after rebooting at the end of the update the pc would tell me that it couldn’t connect to wifi then it wouldn’t respond to any command(even via tty), I had to delete the rtl8821 driver and remove rtw8821 from the blacklist. Does anyone have any idea how this is possible and if there is a solution?

p.s. sorry for bad english

You could just have tried rebuilding the package before rebooting. (Well, I say could, but you should’ve done so anyway since it’s good practise to rebuild all AUR packages after an upgrade.)

pamac build rtl8821ce-dkms-git
1 Like

I have already tried to rebuild it after removing it. It keeps giving me the same problem

In that case:


I suggest you comment on comment, ask for help, or flag it - if appropriate - as out-of-date on the AUR page, seeing as AUR packages are unsupported:

I am experiencing the same issue (aur wifi driver not working and freezing the desktop to an ugly grey) on a desktop pc with kernel 6.1.66. dkms loads this driver GitHub - RinCat/RTL88x2BU-Linux-Driver: Realtek RTL88x2BU WiFi USB Driver for Linux Updating this / re-installing did not solve anything.
BTW On Arch the same update caused the same problems.

I have rolled back the update with timeshift and not sure what to do next.

edit: see this topic: Several problems after 2023.12.10 Stable Update - #3 by Wollie

edit dec 12 21:00 CET: redone update, kernel 6.1.66-2: wifi is now OK!


With 5.15 kernel it works fine. I had the problem only with 6.6 and 6.1.

1 Like

check it if you’ve got all the necessary bits and bobs installed, and make sure your kernel headers match the version you’re running.

Fixed with update to 6.6.5-3 kernel

In the future, be more specific: Which kernel, how to ensure both headers and kernel are in sync exactly

Thank you for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.