Problem With Virtual Machine Manager KVM Network Not Connecting

I have used QEMU/KVM with Virtual Machine Manager for a long time but recently reinstalled Manjaro with the same configurations, settings and desktop environment.

I configured KVM on my newly installed Manjaro OS and now can’t connect to KVM virtual networks.

When I try to start a network, I receive this message:

Error starting network 'default': internal error: Failed to initialize a valid firewall backend

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/", line 65, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/", line 101, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 69, in start
  File "/usr/lib/python3.9/site-packages/", line 3463, in create
    raise libvirtError('virNetworkCreate() failed')
libvirt.libvirtError: internal error: Failed to initialize a valid firewall backend

I am using an x86_64 architecture, GNOME desktop environment, LUKS encrypted SSD, Linux kernel 5.15.7-1, and fully upgraded operating system and firmware.

My computer has support for virtualization and I have used it with Manjaro with KVM on it without this issue. The Manjaro installation was also verified. I even switched to an LTS kernel (Linux kernel 5.10.84-1) to see if it solves the problem, but still no luck. This entire thing seems to be a new issue.

Is there a workaround or solution for connecting to a network on KVM without this error? This error stops me from connecting to a virtual network. GNOME Boxes and VirtualBox are not a solution as I specifically need to use KVM. I really can’t find any information on this problem.

EDIT: Network modes ‘Open’ and ‘SR-IOV pool’ can be started, but I have not tested it as I need to use NAT.

Can you verify that update status?

sudo pacman-mirrors -f && sudo pacman -Syyu


Has me wondering if its looking for something like ufw and it is not installed?

I updated the mirror list and did just that. Everything is up to date.

ufw is installed, although I wonder if there are any missing dependencies perhaps?

From libvirt - ArchWiki
Note: If the default network cannot be started, make sure iptables-nft and dnsmasq are installed.

For reference:
I have ebtables & dnsmask installed explicitly, there is a iptables-nft in the core repo, not sure why I don’t have that installed.

Thank you very much, this solved the problem. I noted that iptables-nft conflicted with iptables but it worked using pamac. For some reason pacman could not install it and displayed an error message about conflicting packages. Do you know why this might be happening?

1 Like

pacman ask if the iptables package should be removed, since it is in conflict with the iptables-nft package. This question needs to be answered.
However the default is no, so pacman will not remove the iptables package if the default answer is used.
The problem is usually that a user doesn’t read the question and just hits enter. The effect is that pacman bails out with an error.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.