Problem with the LCD screen when rebooting Pinebook Pro

At the spinner wait about 10 seconds and press the Esc key.

I tried to install Manjaro ARM KDE multiple times and a few times it failed with “Authentication failed” “automatic login failed” or something similar. (this was with older images - xcfe-pbpro-20.06 and kde-plasma-pbp-20.08)

Now I got kde-plasma-20.10 booting again. After I go through the system set up wizard (user name, pw, locale etc) it reboots. Again spinner keeps spinning and pressing esc shows an error message in the console “EXT4-fs error (device mmcblk1p2): ext4_check_bdev_write_error:215: comm systemd-hwdb: Error while async write back metadata”

Maybe something went wrong with the previous kernel upgrade? How come I can’t even boot Manjaro from SD card? I could boot PBP debian (mrfixit) from SD card. But I don’t think this will help me recover/re-install Manjaro on my PBP =(

Are you using the same sdcard? If not try a different sdcard.

Thanks @Darksky I’ve been juggling multiple SD cards. So I just tried a different one (not ext4_check_bdev_write_error) and now (after going through the wizard) I see

EXT4-fs error (device mmcblk1p2) in ext4_do_update_inode:5087: Journal has aborted
EXT4-fs error (device mmcblk1p2): ext4_dirty_inode:5853: inode #162587: comm systemd-sysuser: mark inode dirty error
EXT4-fs error (device mmcblk1p2) in ext4_dirty_inode:5855: IO failure
EXT4-fs error (device mmcblk1p2): ext4_journal_check_start:83: Detected aborted journal
EXT4-fs (mmcblk1p2): Remounting filesystem read-only
EXT4-fs error (device mmcblk1p2): ext4_journal_check_start:83: Detected aborted journal

Afterwards I flashed the debian mrfixit image on the same SD card and it boots just fine =/

@Darksky not sure what’s going on with my SD cards, I tried multiple but Manjaro doesn’t boot on any of them.

But I might be one step closer to figuring this out. I flashed Manjaro on USB (not sure why I didn’t think of that earlier) and now the PBP boots - and it does boot into the existing installation on eMMC (it’s prompting me for my existing user’s pw).

My guess is that the name of the USB BOOT_MNJRO and my /etc/fstab contains LABEL=BOOT_MNJRO /boot vfat defaults 0 0

However the network is not available. ip a returns only the loopback interface.

My current kernel according to uname -a is Linux pinebookpro 5.8.14-1-MANJARO-ARM #1 SMP Wed Oct 7 09:18:37 CEST 2020

And pacman still has the following in its cache


lsblk returns

sda (30G) - that's my USB
- sda1 213M (mount point /boot)
- sda2 4.9G
mmcblk2 58.2G
- mmcblk2p1 213.6M (no mount point!)
- mmcblk2p1 58G (mounted at /)
mmcblk2boot0 4M
mmcblk2boot1 4M
zram0 5.6G [SWAP]

So what’s my move here? Shall I revert the kernel using the latest 5.7 from my cache? How do I do that?

Thanks again so much for your help, I love Manjaro on my PBP

@spikerguy or @Strit would better suited to answer your questions. I do not have a PBP.

1 Like

This is likely because of the mismatch of kernels.

The network is a module from the kernel and so it will only load of that version of the kernel is actually loaded.
If you check uname -a you will notice that the kernel version loaded, does not match the kernel package installed. This is because the wrong /boot partition has been mounted. A downside of running Manjaro on both eMMC and SD/USB. This happens sometimes.

We need to figure out why your eMMC install does not boot.
So if you shutdown the PBP and unplug everything. Then boot the device. How far does it get?

Hi @Strit thanks for having a look at this.

I installed updates (via package manager UI) on my PBP a few days ago, it felt a bit sluggish after so I shut it down and next day it didn’t boot anymore.

With everything unplugged and then starting it:

  1. orange power LED for a few sec
  2. power LED turns green
  3. nothing… the only thing it seems to do is toggling the num/caps lock LED when pressing those keys

Okay. So the system is booted and the kernel is running. That’s a good sign.

There’s nothing on the screen at all?
Can you get to a TTY?
Can you access it via SSH?

Nope the screen is completely black. I’ll try SSH!

It seems that the USB label is confusing things, so it boots BOOT from USB but ROOT from eMMC.
Would it make sense to try to change the label of the USB and hopefully it fully boots from USB and I can do a fresh install on eMMC?
If things are easy to repair that’d be great but otherwise I wouldn’t mind having to do a fresh install I have everything I need backed up :slight_smile:

Probably easiest to just re-install then. It does not take long. You can even do it from a booted SD card and an internet connection, with the Manjaro ARM Flasher.

weird even when I rename the boot partition on the USB it keeps booting (with USB) into the eMMC installation.

Maybe I should just try to install another distro and then it should boot properly from the USB (Manjaro) or is there a better way to force it to boot from USB only?

Boot into the existing system.

Rename Label ofROOT_MNJRO on SDCard to SD_ROOT_MNJRO and then change root=LABEL=ROOT_MNJROtoroot=LABEL=SD_ROOT_MNJRO` in sdcard BOOT_MNJRO’s extconfig

Reboot, If I am understanding your situation correct then this will boot from SD card with root on sd card itself.
then you can reinstall the kernel if needed or chroot to emmc to fix whats broken on emmc.

USB Boot I don’t think you can boot from usb afaik.

@spikerguy thanks for the tip about renaming the labels. That worked and I booted from USB (seems to work just fine in general) and went through the install wizard. PBP rebooted and added the user, extended the partition etc but the next reboot just kept showing the Manjaro logo and spinner - pressing ESC just showed a blank screen with a blinking prompt but couldn’t type anything.

When trying the same with an SD card I got some Journal errors from the mlsblk2 device.

I was able to boot mrfixit from SD card no problem.

Is there a way to easily install a different distro to wipe out Manjaro from eMMC, then properly install Manjaro (I guess using the installer?)

You can boot from the usb as you said it works then just dd the entire emmc drive with zero, with this you will lose all the data on emmc including the uboot u have on it.

Then you can run anything over sdcard

Personally, and still at this time, I blanked emmc uboot area,
there’s lots of “bad” uboots out there
Save mbr, 1 sector (count=1) unless gpt(count=34 )
dd /dev/zero to 1st 16M (bs=1M count=16)
restore mbr
bsp uboots seem more reliable, AND make s3 sleep possible
How to boot emmc? A small card with ONLY uboot on it
(well, mbr, idbloader, uboot, trust)
I should say that there are damn few distros that can do s3, many fail to wake

@wdt @spikerguy @Strit thanks for all your help - and all the amazing work you do in the pine 64, manjaro and ARM community.

I managed to get my PBP operational on Manjaro again. I booted mrfixit debian from SD, then installed that one to eMMC. Then I could boot Manjaro from SD and then use the arm installer to install it on eMMC.

Sleep was a problem for me in the past, not sure if it’s better now or that still needs work in the future.

Thanks again!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.