Problem with the LCD screen when rebooting Pinebook Pro

Just received my pinebook pro ANSI. And having the same problem…

1 Like

I have an ANSI pinebook pro and I also see this issue.
If you boot from an SD card and then reboot, you end up in the eMMC
I think that uboot is still running and it believes that the OS you are rebooting from failed to boot, so it launches the next priority boot.


So the only drawback of reverting to bsd uboot is that the suspend won’t work anymore right?

My system is running on an NVMe, starts from EMMC. I think there is no suspend possible ATM. Regardless off the U-Boot. PBP goes to sleep and wakes up after 6 seconds. Or is this solved by any U-Boot version?

I didn’t have any issues with suspend on any U-Boot. There is only a risk of possible bricking PBP during flashing U-Boot files to the eMMC module. If the U-Boot on the eMMC got corrupted it might not boot even from SD card, if you have a bad luck. Moreover the only person who knows what’s in this U-Boot is mrfixit2001 or the aliens/illuminati/reptilians (I’m not saying that mrfixit2001 is one of them, but I don’t know if he is the one who built it). But you will be able to boot any other OS (from the list and some of them will be able to power down PBP (with mainline U-Boot the previous default OS had problems with it, but I didn’t check it again, yet).

Err, with working s3, suspend 3(what dmesg calls it), s2ram, ~7%/d
s2idle is, oh say, 10-12 times worse, FWIW
And, the point, for s3 you MUST have bsp uboot and no nvme
(and the “right” kernel)

Perilous… Thanks for the info mate, you got me scared… I might just wait until there is an update which might fix the issue if enough people has the same problem. Until then, not use reboot…

PBP has much worse problems with charging than with suspend. It can drain more power than the power supply can provide, it stops or interrupt charging (which causes waking up from suspend after a few seconds) when the board temperature is over forty something Celsius, in the summer when there was over 30 degrees Celsius outside and simply turning on the PBP would cause it to stop charging or using the power supply.

Are these problems specific to a certain uboot?

IMO no,

the loading problem exists, the charger is absolutely HOT and no more power can be delivered.

These are the hardware problems but the blinking red LED next to DC-In is waking up PBP from suspend.
There are more hardware problems like, e.g. I can hear right channel on left channel and vice versa (it doesn’t matter on built-in speakers or on wired headphones), but it can be annoying maybe, the crosstalk between audio output and serial console could interpret loud noises as magic SysRq combinations, effect: random crashes on certain U-Boot and kernel configurations caused by cranked up to distortion sound output (source: Review of Pinebook Pro).

Is your display issues resolved?

Latest updates from Manjaro done, display problem on startup are not fixed

Unfortunately not. I did’t install the bsp uboot tho…

Hey guys,

After using my PBP happily for months now it doesn’t boot anymore =(

Yesterday I installed latest updates (Manjaro KDE) via package manager - afterwards it felt a little sluggish so I decided to shut it down in the evening (to reboot the next day).

When I press the power button, the power LED is orange for a few seconds an then turns green - but the screen stays off. I noticed that I can press caps lock and num lock (fn+f10) and it toggles the appropriate LEDs.

I also tried booting from SD card (also Manjaro KDE) and at first it prompted me for system set up info (user name, pw, root pw, locale, tz etc) but then was just showing the Manjaro logo and a spinner for at least half an hour.

Any help much appreciated!

At the spinner wait about 10 seconds and press the Esc key.

I tried to install Manjaro ARM KDE multiple times and a few times it failed with “Authentication failed” “automatic login failed” or something similar. (this was with older images - xcfe-pbpro-20.06 and kde-plasma-pbp-20.08)

Now I got kde-plasma-20.10 booting again. After I go through the system set up wizard (user name, pw, locale etc) it reboots. Again spinner keeps spinning and pressing esc shows an error message in the console “EXT4-fs error (device mmcblk1p2): ext4_check_bdev_write_error:215: comm systemd-hwdb: Error while async write back metadata”

Maybe something went wrong with the previous kernel upgrade? How come I can’t even boot Manjaro from SD card? I could boot PBP debian (mrfixit) from SD card. But I don’t think this will help me recover/re-install Manjaro on my PBP =(

Are you using the same sdcard? If not try a different sdcard.

Thanks @Darksky I’ve been juggling multiple SD cards. So I just tried a different one (not ext4_check_bdev_write_error) and now (after going through the wizard) I see

EXT4-fs error (device mmcblk1p2) in ext4_do_update_inode:5087: Journal has aborted
EXT4-fs error (device mmcblk1p2): ext4_dirty_inode:5853: inode #162587: comm systemd-sysuser: mark inode dirty error
EXT4-fs error (device mmcblk1p2) in ext4_dirty_inode:5855: IO failure
EXT4-fs error (device mmcblk1p2): ext4_journal_check_start:83: Detected aborted journal
EXT4-fs (mmcblk1p2): Remounting filesystem read-only
EXT4-fs error (device mmcblk1p2): ext4_journal_check_start:83: Detected aborted journal

Afterwards I flashed the debian mrfixit image on the same SD card and it boots just fine =/

@Darksky not sure what’s going on with my SD cards, I tried multiple but Manjaro doesn’t boot on any of them.

But I might be one step closer to figuring this out. I flashed Manjaro on USB (not sure why I didn’t think of that earlier) and now the PBP boots - and it does boot into the existing installation on eMMC (it’s prompting me for my existing user’s pw).

My guess is that the name of the USB BOOT_MNJRO and my /etc/fstab contains LABEL=BOOT_MNJRO /boot vfat defaults 0 0

However the network is not available. ip a returns only the loopback interface.

My current kernel according to uname -a is Linux pinebookpro 5.8.14-1-MANJARO-ARM #1 SMP Wed Oct 7 09:18:37 CEST 2020

And pacman still has the following in its cache


lsblk returns

sda (30G) - that's my USB
- sda1 213M (mount point /boot)
- sda2 4.9G
mmcblk2 58.2G
- mmcblk2p1 213.6M (no mount point!)
- mmcblk2p1 58G (mounted at /)
mmcblk2boot0 4M
mmcblk2boot1 4M
zram0 5.6G [SWAP]

So what’s my move here? Shall I revert the kernel using the latest 5.7 from my cache? How do I do that?

Thanks again so much for your help, I love Manjaro on my PBP