Problem with PulseEffects

pulseaudio

#1

Hello. I am new to Manjaro. I am not a linux pro or anything but i can get around. I managed to install pulseeffects [I have a few presets already]. It installs fine and then when I open it, start to play music and flip the little switch on at the bottom [to activate it], it doesn’t work. I can also hear my microphone, too.

I didn’t have an issue with it on Kubuntu but that distro was messing up for me so I switched to Manjaro. And Google didn’t really work out for me. I also tried just the plain Pulse Equalizer and it won’t load my presets – and and it’s just not the same.

I’ve tried looking at Pavu also.


#2

I moved the topic to #technical-issues-and-assistance:aur, since PulseEffects is an AUR package.

Try creating a new preset and see if that works?


#3

That didn’t work either, sadly.

When I flip this switch, no sound comes through:


#4

Is it set to correct output device?


#5

When I flip the switch, it goes to “PulseEffects(apps)” but the audio mutes out.

I haven’t messed with any of the audio settings. On the other distros, it worked “out of the box”


#6

It might be that those ‘other distros’ have other software defaults which makes PulseEffects work.

Have you checked if you miss a dependency - like jack ?

Have you checked with ‘pavucontrol’ that sound is going to the right output?

Does PulseEffects use perl? If so has it been recompiled after the switch to versioned perl?

https://www.archlinux.org/news/perl-library-path-change/

Have you read the comments on the package home at

https://aur.archlinux.org/packages/pulseeffects


#7

Yes, I checked the pavu settings.

I don’t know how to check for the dependency or if it uses perl [this thread was originally in the newbie section]

I think I will switch to another distro. Thanks for trying to help.

You can close the thread


#8

Actually, it’s odd… it worked on Kubuntu, but not on Manjaro - and I’m on the Linux Mint [KDE] live USB right now and it’s not working either.

and yes, I was sure to read those comments.

This is strange though…


#9

I tried pulseeffects, but only briefly as it didn’t suit my needs, so not 100% sure how I got it working within Pulseaudio

It looks from your screenshot that sound is getting in to the effects ok, just not getting out

When you were checking Playback tab in Pulseaudio Mixer [pavucontrol], did you have the option at bottom of window set to “Show: All Streams”?
If it is only set to “Show: Applications” you won’t see pulseffects virtual stream to adjust settings you need.

Check Recording tab is showing all streams too - that would probably be place to look at settings to stop microphone audio going to effects

AUR packages won’t always work ‘out of the box’, depends on the individual maintainer.
Comment on AUR page from package maintainer 2017-08-19 suggests there are still some things need work on this package, and it has only been on AUR for 6 months.
This may not be something used by many people on Manjaro so you need to allow a lot more time for getting answers on here compared to the packages maintained in Manjaro repositories


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.