Problem with nvidia GPU driver(nvidia GeForce GT 750M)

My maaann :slight_smile: @rescue88, you are clearly hiding some of the output from the inxi -Gazy. I don’t know why, but you are, hence is harder to help you.

So here is mine and you compare with yours, so you can have a clear picture of what is going on.

$ inxi -Gazy

  Device-1: Intel Core Processor Integrated Graphics vendor: ASUSTeK
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300
  Device-2: NVIDIA GT216M [GeForce GT 325M] vendor: ASUSTeK driver: nvidia
  v: 340.108 alternate: nouveau bus-ID: 01:00.0 chip-ID: 10de:0a35 
  class-ID: 0300
  Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting,nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
  s-diag: 485mm (19.1")
  Monitor-1: LVDS-1-1 res: 1600x900 hz: 60 dpi: 106
  size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
  OpenGL: renderer: GeForce GT 325M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
  direct render: Yes

I use different setup than yours, but you can compare nevertheless.
Pay attention to Device-2 driver and v:. Mine is 340.108, yours should be 390.xx

My suggestion is to reinstall the driver, rather the package. The easiest way should be through mhwd. You can find a lot of posts on how to do that. Good luck :four_leaf_clover:


Yes, im hiding unnecessary info, because my monitor drivers and other things does not matter at all i guess.

Ive tried to install via

mhwd -a pci nonfree 0300

Or manually via

mhwd -i pci nvidia-hybrid bla bla bla

But something goes wrong and driver still N / A. I do reinstall more and more, but no results.
On my main PC all was OK, drivers set automatically, but laptop is unlucky one.

Maybe i should try another versions, but, for example, for me smth like 418xx or others not exists (nvidia official website finds 418.* version the best for my gpu).

Daft question but did you reboot after installing the drivers? What does it say when you use mhwd to install the drivers,it should give you an error message if it fails

ofc i do reboot after all the manipulations)

If i try to install other drivers(like guys in other topics as well), getting this error:

Error: config ‘video-hybrid-intel-nvidia-390xx-prime’ does not exist!

Is there any way to list all available driver versions for me to install ?

The 390 prime driver doesn’t exist, if you are installing 390 from the repos it’s video-hybrid-intel-nvidia-390xx-bumblebee

I’m definitely no expert on this, hopefully someone more knowledgeable can confirm

Yeah, this one installs by default or with:

mhwd -a pci nonfree 0300

Still N / A with output of

inxi -G

I can’t find package with 418.xx for linux, so your best bet would 390.xx.
Have you tried to use nvidia-390xx-dkms ?? from AUR ?? and only use nvidia as primary driver no bumblebee and the other stuff (just to see if it works).

Oh… and

Can sometimes matter.

I hope someone more knowledgeable can help you solve this.

EDIT See this page in case you haven’t. Configure_Graphics_Cards-Manjaro

1 Like

I’ve never used bumblebee only prime but if you launch

primusrun glxgears -info

Do you get anything or if you use primusrun to launch anything does anything happen

Few minutes ago i’ve installed video-nvidia and it worked, replaced N / A with v470.*, but… It seems incompatible with my devices, so the system wasnt able to start. Instead i got into terminal via Ctrl+Alt+F2 and deleted it :frowning:

I know it’s a silly question, but does inxi show a driver for both graphic cards, or only for the active one?

Yeah, i see the picture with 3 bolts with infinite spinning.

The output is

GL_VERSION = 4.6.0 NVIDIA 390.144
GL_VENDOR = NVIDIA Corporation

And GL_EXTENSIONS which are not readable.
Here is the text at the end:

301 frames in 5.0 seconds = 60.092 FPS
301 frames in 5.0 seconds = 60.102 FPS
301 frames in 5.0 seconds = 60.093 FPS
301 frames in 5.0 seconds = 60.096 FPS
301 frames in 5.0 seconds = 60.092 FPS
301 frames in 5.0 seconds = 60.100 FPS
301 frames in 5.0 seconds = 60.095 FPS
301 frames in 5.0 seconds = 60.092 FPS
301 frames in 5.0 seconds = 60.097 FPS
301 frames in 5.0 seconds = 60.099 FPS
301 frames in 5.0 seconds = 60.094 FPS
301 frames in 5.0 seconds = 60.097 FPS
301 frames in 5.0 seconds = 60.098 FPS
301 frames in 5.0 seconds = 60.095 FPS
301 frames in 5.0 seconds = 60.093 FPS

The only version that should run is 390 or nouveau. Other won’t work.

EDIT Wow… This is strange. :slight_smile:

According to this nvidia is working… :slight_smile: :thinking:

1 Like

It should show for both. Device 1 and Device 2. The active one is shown in display and renderer, I guess.
Take a look at mine above :point_up: in eralier post.

Still have unknown renderer :smiley: via inxi -Gazy

OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.1.5 compat-v: 3.0 direct render: Yes

I guess its because you are using hybrid, so the renderer is the Mesa DRI Intel HD…
Not sure though :man_shrugging:
I use only nvidia, no other stuff. That’s why mine shows nvidia.

But, again to why your Device 2 doesn’t show the driver :man_shrugging: .
I think it should show at least the v: and the driver could show something like hybrid or bumblebee
or whatever along those lines.

Yeah, thats weird, so i decided to search an answer here. Similar topics won’t help me :frowning:

Maybe i should read smth about how to switch between gpu devices…

Finally, nvidia-390xx-dkms is the solution, thanks. Now i got 390.** driver for GPU device #2 displaying via

inxi -G

All works fine as well. To change OpenGL renderer is enough to install optimus-manager from AUR and set nvidia using

optimus-manager --switch nvidia

One more time thanks !


No problem :slight_smile: . I’m glad you solved it.
Cheers… :beer:

Ok, here is the best solution for me.
Ive installed 470.* drivers via AUR and inxi -G displayed the same: device #2 driver: N/A.

If you switch into nvidia via

optimus-manager --switch nvidia

All drivers will be displayed correctly. So maybe the default driver, which installs by:

mhwd -a pci nonfree 0300

would work too, who knows(in my case its nvidia-intel-hybrid…390xx-bumblebee, smth like that).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.