Problem with Notebook & Displaydock

Hey there,

I’m using a Notebook with a AMD Ryzen 7 6800U with Radeon Graphics CPU.
As Dockingstation I use a Dell WD19 and I have two external Displays + the Notebook screen active.

Everything works fine for the whole day.
I only got one problem and I think it’s a GPU problem.

When I play a game of chess on chess[dot]com the dock seems to randomly loose the connection and the Linux never recovers from that. I have to hard reset the Notebook then.
journalctl gives me the following output.

[drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring sdma0 timeout, signaled seq=87152, emitted seq=87154
[drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process  pid 0 thread  pid 0
[drm:check_syncd_pipes_for_disabled_master_pipe [amdgpu]] *ERROR* DC: Failure: pipe_idx[2] syncd with disabled master pipe_idx[1]

Can anybode help me?


Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Hello @LeeroyVinland :wink:

Yeah, I see here that you are not alone with this issue: [amdgpu]] *ERROR* ring sdma0 timeout (#2220) · Issues · drm / amd · GitLab

Looks like it has something to do with WebGL and VAAPI in conjunction with some specific AMD iGPUs, when using a Browser.

Maybe try a stress test: WebGL Stress Test and see if you can reproduce this timeout.

You can disable it in Firefox at about:config

  • webgl.disabledtrue
  • media.ffmpeg.vaapi.enabledfalse

That is a downgrade for sure, but maybe it helps as a temporary workaround.

It was reported that you can switch the TTY like CTRL + ALT + F1 - F7 and switch back to the graphical TTY. Then it works again.

I am not quite sure what the problem is, but for sure, it is a driver bug.

Maybe try another LTS kernel and see if it more stable there, since the amdgpu module is baked into the kernel.

Hello @megavolt

I googled and searched the web for like ages and didn’t find this error.
Disabling WebGL and VAAPI in FireFox is exactle the fix I needed.

Everything runs fine now (dispite missing some anymations but it’s ok)

Thank you so much!

Next time I will use proper formating! :grinning:



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.