Problem with Grub entry at boot/kernel options [SOLVED !]

Hello everybody,

I am running Manjaro Cinnamon and I am feeling deep satisfaction with it. Everything works but I would like to use a LTS kernel instead of 5.8.xx. Unfortunately, I have a problem to get into the grub entry with my installed kernel options. I have read some threads here, I tried to change the config files with nano but no key stops booting into the original kernel from the current Cinnamon iso 20.1.
Please keep in mind that I am not Mr. Wonderful.

Welcome to the forum! :slight_smile:

You have to make sure that /etc/default/grub has a proper timeout set, and that it shows you the menu.

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu 

Then you must update GRUB ─ I’m assuming that you’ve already installed the LTS kernel ─ like so… :arrow_down:

sudo update-grub

If you still need to install the LTS kernel, then do the following before updating GRUB… :arrow_down:

sudo mhwd-kernel -i linux54

Hope this helps. :wink:


Note: After all of the above, you will have to select the “Advanced options for Manjaro Linux” item in the menu in order to be able to select the 5.4 kernel, but on the next reboot after that, GRUB will remember that choice and will boot the 5.4 kernel. :wink:

I’m running manjaro-cinnamon edition myself, if you just want to access the grub menu then hold shift while booting and it will appear.

I am very pleased with the speed of help offered here. Thank you.

I did what Aragorn has suggested and also what sawdoctor has mentioned. It dos not work yet.
I will try again and give a feedback. To sum it up. The system works nice and I think i is just a minor problem probably due to my lack of knowledge.

Just a wild guess, but is this a BIOS installation or a UEFI installation?

Thank you for your help.

So, now we dive into into the World of Linux.
I have repeated a few times what has been suggested but the problem seems to be caused somewhere else.
If I remember right, I have used Etcher to make the USB-ISO, checked my BIOS settings (there: UEFI) and started the USB via BIOS first to get the USB listed there and started the whole procedure.

Are you actually using GRUB as the boot loader? I’m asking because there are yet other methods of getting the kernel to boot.

  • systemd-boot, which requires the EFI boot manager to select the kernel or operating system
  • refind, which is a slimmer EFI boot loader than GRUB

Please tell me how to check this, I am not competent enough.

Well, if you don’t know, then it’ll most likely be GRUB. The other methods require deliberation on account of the system administrator. :wink:

Puh… :grinning:

Can you post the contents of your /etc/default/grub, please? Click on the </> button in the toolbar of the post editor and paste the output in between the two lines of three backticks (```).

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

Sorry, messed it up.

I’ve edited your post.

Remove that line from the file, save it, and then run… :arrow_down:

sudo update-grub

I think the theme part is missing in /etc/default/grub. Something like:

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"
1 Like

Really, thank you for your help. But I start to feel horrible because I dislike to steel your time. Obviously my fault.
Let’s stop it right now and let us appreciate the fact that the standard kernel 5.8.xx works. Give me a break, I have had a mixed day in my life. I am checking all the suggestions again tomorrow.

AND THE GOOFY AWARD SEPTEMBER 2020 GOES TO ---- ZWACKELMANN!

The solution is that simple (but perhaps interesting for others):
I have installed Manjaro Cinnamon with UEFI enabled in my BIOS settings. The problems are written here in this thread.

Just out of curiosity I changed this setting in my BIOS from UEFI to LEGACY, changed in my GRUB entry just one line (GRUB_TIMEOUT_STYLE=menu) and now it works.

Solved!

@Zwackelmann Please use the solution button to mark a post as solution. No need to writing it into the title :wink:

@megavolt
Ups. Quality comedy, I haven’t seen this pretty fat button.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.