Problem with graphics driver on a fresh new install

Hello lovely Manjaro users and contributors :heart_eyes:

Intro: Recently (few days ago) I installed Manjaro 6.6.10-1 on my machine alongside Windows 11. Manjaro is installed on a separate SSD.

Branch: Stable
CPU: i7-9700k 3.6GHz
GPU: GeForce GTX 1080
Kernel: 6.6.10-1-MANJARO
Bootloader: GRUB
Architecture : x86_64 (AMD64)

Problem: I have two problems:

  1. Waking up the machine leads up to no signal situation. So randomly, in 50% of the situations when I wake up the machine after 10-15 mins of inactivity, it gets me to a point where the monitor shows No Signal. (Using 5k 49" Odyssey G9 on Display PORT).
  2. Again randomly in 50% of the situations after a restart, I enter password and then the loading bar fills in and it freezes there. I can move the mouse but nothing else is happening.

Steps I took: After looking at the some of the other discussions, I tried installing the proprietary graphics driver, but that lead me to a scaled (640x480) black screen on which I cannot do anything. The only way to mitigate that is by logging in through Ctrl + Alt + F3 and running startx. If I uninstall the proprietary nvidia driver, I get back to normal screen, but I start running in the problems stated above.

Additional info
Output from mhwd -l:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2023.03.23               false            PCI
video-nvidia-470xx            2023.03.23               false            PCI
video-nvidia-390xx            2023.03.23               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

Output from mhwd -li

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2023.03.23               false            PCI
       video-linux            2018.05.04                true            PCI

So any advice is welcome.

Thank you.

That sounds like the symptoms I had with C-State problems. Try disabling C-States in BIOS.
If that works gradually turn them back on(different levels) until it doesn’t. One step back, perfect.

The proprietary driver should work. Try renaming the xorg.config and xorg.config.d file so X11 starts with no config. How did you install proprietary drivers?

Used the following command: sudo mhwd -a pci nonfree 0300

Are you suggesting disabling idle C-States while having the proprietary driver installed ?

x11 directory doesn’t exist in /etc/ (started the system using Ctrl + Alt + F3 → Login → startx)

First just disable C-States. Don’t change 2 things at a time so we can rule things out reliably.

X11 config might not be there because of your drivers. Forget about them for the moment. Don’t know.

Have you tried installing drivers via the settings? Should work, otherwise: sudo mhwd -i nvidia

1 Like

Disabling C-States helped for starting up the system after idle. Thanks :pray:

Although the problem with black screen on Ctrl + Alt + F1 remains when I install NVIDIA driver.

Great to hear. Sorry for the late reply. I’m really just guessing here but could be your display server throws an error. On the bottom left there’s a switch, make sure it’s on X11, Wayland won’t just work on NVIDIA and will lead to that exact symptom but if it’s on X11 forget about that.

If you’re on X11 go to /etc/X11 and rename all the files in there by adding some character at the end so X11 won’t find them. If that works your config is probably pointing to the wrong driver. Careful this messes with your keyboard layout so keep that in mind when entering your password.

If this breaks stuff even more just undo the renaming in console and you’re back to initial state.