Problem with folder color on gnome (with Nautilus)

Hi everyone,

i just switched from ubuntu to manjaro, and i’m very happy of all of the new things i’m discovering !
However, i really like to have different colored folders, it helps me organizing my stuff.
So I got the package “folder-color-nautilus” but it doesn’t work… It was properly installed, but when i right-click on a folder and i choose the color, nothing happens. I also tried to install “folder-color-bzr” but the installation failed with the error “./ not found”.

Do you have any tip on that ? Maybe another way to change the color of folders ?

thanks in advance for your help !

Hi @hynreck1, and welcome!

Please note:

I don’t use Gnome, nor have I even heard of the feature you spweak of, so this is purely internet research.

Based on this answer I deducted that you might not have the functionality. At least not by default.

So I checked in the AUR for the extension. And whadya know?! It seems to be there:

$ pamac search desktop icons
gnome-shell-extension-desktop-icons                                                                                                                                                                                          20.10.0-1            AUR
Add icons to the desktop

So it might be as simple as installing that and you can do that with:

pamac build gnome-shell-extension-desktop-icons

However, like I said. I don’t use gnome, so there is no way for me to be :100:% certain. So reboot and test if it worked.

Hope this helps!

Thanks for your quick answer !
Unfortunately, this doesn’t work… It still doesn’t do anything when i try to change the color.

Is the extension enabled? (If you have to do this, I wouldn’t know.)

Yes, i enabled it. It’s quite nice by the way :slight_smile: I have beautiful icons on my desktop, but it doesn’t solve the initial problem.


I noticed something about the “Desktop Icons NG” as well, and it is in the community repository:

$ pamac search desktop icons
gnome-shell-extension-desktop-icons-ng                                                                                                                                                                                       47-1                 community
A fork from the official desktop icons project, with several enhancements like Drag'n'Drop.

So you could always try replacing gnome-shell-extension-desktop-icons with it:

  • First, remove gnome-shell-extension-desktop-icons:
pamac remove gnome-shell-extension-desktop-icons
  • Then, install gnome-shell-extension-desktop-icons-ng:
pamac install gnome-shell-extension-desktop-icons-ng

If that doesn’t work, I’m all outta ideas. So, I hope it helps!

No, still stuck at the same place. I restarted, and even reinstalled folder-color.

  • To check if it’s installed globally, it should be listed when you execute:
ls /usr/share/gnome-shell/extensions/
  • To check if the extension is installed for the current user it should be listed when you do:
ls ~/.local/share/gnome-shell/extensions/
  • To check if it’s enabled, it should be listed when you execute:
gsettings get enabled-extensions

It also might be that it doesn’t work even if it is installed due to a version incompatibility, and if that’s the case, I think you’re kind of out of luck. But I’m no expert and I might be wrong.

Thank you a lot for the details ! The extension is indeed listed everywhere you pointed (under the name “ding” ). It’s installed globally, for the current user and it’s enabled.
So i’m beginning to think i’m out of luck… That’s a shame because it worked on ubuntu right out of the box, and it also work on my gaming PC which is on garuda (gnome). So i really don’t understand what is wrong.

I don’t know either.




Did you restart Nautilus after installing the package? It works for me.

Close any Nautilus windows, then completely exit:

nautilus -q

Now open Nautilus again.

Yep, I entered this command, still the same.
However, i got this message when i launch nautilus in the terminal

nautilus cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/gio/modules/ cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/gio/modules/

I don’t know if it’s linked to the problem…

All those missing libraries belong to gvfs. Try reinstalling it:

sudo pacman -Syu gvfs
1 Like

You are so smart ! It’s working now :slight_smile: Thanks a lot !!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.