Problem with Firefox- Gecko Main pigging CPU after upgrade to 96

System HP Pavilion Laptop Ryzen 7 4800 NVidia 1650TI Kernel: 5.16.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.23.4. Upgraded Firefox yesterday to 96. Everything was fine for a number of hours although I have noticed recently that Gecko Main really has been hitting the CPU pretty hard --Installed PaleMoon a week ago because of this and am on that now… about an hour ago browsing Firefox a page would not load. About 10 seconds later the fans on the laptop spin up. I think hmmm I wonder. Opened a terminal and tried pinging various places both IP and name (to check the DNS server)everything fine…then the fan increased more, I popped the process table and sure enough Gecko Main is chugging CPU cycles. Killed the Firefox window and Gecko Main continues for another 45 seconds then I get a “We’re sorry Firefox has crashed wanna restart or quit?” So I quit, then restart and try to immediately go to troubleshooting mode and no joy…it is hung, wont restart through this path, wont browse and although I can close the window i have to kill -9 Gecko Main to rid myself of it pigging the CPU. So it is odd to me that this problem happens out of the blue and the way it has… Anyone else experience this?? Random cosmic ray flipping a bit on my SSD?

EDIT–rebooted into 5.15.12-1 and 5.10.89-1. Both kernels give the same result. Will not browse when started, Gecko Main pigs the cpu and when the window is closed, Gecko Main acts almost like an orphaned process. Also can not get into Safe mode…oh wait thats troubleshooting mode. When that path is tried Firefox crashes.



Same problem here. I even deleted my profile to see if it would help. I got it to work maybe for a minute, then same problem again. Disabling all extensions also doesn’t seem to help.

The same to me, I see that there is ff v 96.0-2 as a snap package: Install Firefox on Linux | Snap Store , I’ll try to use it next time the problem will appear.

If you’re having trouble with #firefox, try disabling HTTP3 in about:config with the ‘network.http.http3.enabled’ key. After setting this and restarting Firefox everything worked again.


Thanks for this. I am curious what tools or line of reasoning you used to arrive at disabling HTTP3? Your remedy and result are interesting. So are you able to tell that HTTP3 in Firefox is the culprit or is it something external to the browser proper. Seems like Moz may have released a buggy version or I wonder if its endemic to Manjaro??
Many thanks…

Alternatively, turn off all telemetry, worked for me.

1 Like

Interesting. My telemetry is already off… Thanks. Something weird no??

EDIT–No it was not. It was in the earlier version but the update re enabled telemetry and remote studies again which I just disabled. Lipstick on the pig.

I had issues with FF not loading websites and the Gecko thread creating high CPU load this morning - but I’m still on FF95.0.2 and the issue seems to have resolved itself now.
Previously neither restarting FF or rebooting would work. Maybe some other issue behind it instead of FF96?

The issue seems to have resolved itself for me too. I’m on 96.0.

I had noticed Gecko porking a week ago and installed Pale Moon because of it. I also saw a problem that seemed to disappear. I also noticed it on 95 on my desktop but it seemed to go back to normal… dont know maybe time for a new browser.

Seems like a buggy update from Mozilla:


Thank you bill_t.

1 Like

I’m just duckduckgo’ed and found
Refering to 1749908 - Infinite loop in HTTP3 hangs socket thread



Good on ya fl4bn4t. I am a little slow on the uptake been up a few hours :slight_smile:
One wonders… after reading some of the thread you found…be interesting as strange as things are…if this were not something in the wild that caused this…
Interesting we get this on 2 different versions in multiple places with no predicted “hard failure” mode…sounds like for most of us that did update it at least worked for a while then kacked no?? So the solution is turning off HTTP3 in about:config. I wonder…with HTTP3 off how much more vulnerable are we…combination maybe of buggy Moz code plus some external actor or place causing HTTP3 to hang.

Narren Welcome to the community. Good distro and great people here on the forum. Welcome !

From the bug report linked above:

Our current suspicion is that Google Cloud Load Balancer (or a similar CloudFlare service) that fronts one of our own servers got an update that triggers an existing HTTP3 bug. Telemetry was first implicated because it’s one of the first services a normal Firefox configuration will connect to, but presumably the bug will trigger with any other connection to such a server. Our current plan is to disable HTTP3 to mitigate until we can locate the exact bug in the networking stack.

Also, the update has apparently been reverted and http3 can be enabled again. Guess there will be an additional fix to FF in the future.


Wonder if the same HTTP3 code is used and enabled in Thunderbird…you know both updated (here at least) same day…Anyone seeing this same Firefox problem on any mobile platforms??

Personally, I have not been affected by these problems so far. After reading the above posts of this topic, I came across the following German-language article.

Mozilla has reported the problems as solved on Twitter. After a reboot the problems should not occur anymore. Mozilla will give more details about the problem at a later time.

1 Like

Thanks for posting the article Piscatorius. I tried using Google Translator to make sense of it but the website wants one to log in no??

So what does it mean that the problem is “solved”…does that mean we are again operating with the safer HTTP3? Or with the change to about:config we are operating with HTTP2?

Not trying to be difficult but I use my machines for financials…crypto, derivatives, banking and so forth. I also live in Ecuador where(at least where I live) the server techs at the ISP dont know the difference between megabits and megabytes— wild west. So if it appears that I am a little “touchy” about things like browsers and IP Table firewalls and security and keeping machines updated, I am . Firefox says the problem is solved. A good thing if in fact it is “solved”…I also run Debian on one of my machines and as of about 2 PM this afternoon they had an alert and update for Firefox-esr…given that we had the broken update some 24 hours before that I found the esr update interesting as well…wonder if it was part of the same update cycle that got us the garbage it did…

Also read the twitter thread put here only thing I was able to discern from it is " restart ya browser"… someone asked “how many times”…there was no technical information on the Twitter feed at least that I found…
Many thanks…

EDIT- for anyone so curious