Problem with Clipboard in KDE Plasma

Hello,
I have the following problem:
When I mark a text with the mouse, it’s automatically copied to the clipboard.
Is there a way to disable this behavior? I only want to copy it when I actually do it (e.g. press Strg+C).

Thanks in advance

I don’t think you can really disable that. It’s the way copy/paste works in UNIX-style operating systems.

GNU/Linux is a UNIX-family operating system, and UNIX is very, very different from Microsoft Windows, which still builds upon lots of legacy behavior from the days of MS-DOS and CP/M.

What you could do is set up a shortcut key to empty the clipboard in the System Settings. On my system, I’m using Meta+Del for that.

Workspace → Shortcuts → Global Shortcuts → Plasma → Clear Clipboard History

:slight_smile:

If you’re talking about konsole (the terminal), there is a setting for that:

SettingsEdit Current ProfileMouseText interaction (tab) → Copy on select (checkbox)

I believe there is a setting in the systray clipboard menu. You can disable that feature there.

1 Like

Like as said @freggel.doe and @daPhipz konsole has a setting for it… and the clipboard of plasma has also this setting.

I never saw this behaviour on any Unix operating system i used, from HP or Sun

1 Like

Well, then your mileage will vary. :slight_smile:

I think as others pointed the problem is within the applications (like Konsole) and with the integrated clipboard from KDE (that by default you can configure from the system tray). You actually have two ‘paste’ actions by default, the one with right click -> paste (after right clicking -> copy), and the one where you click with the middle mouse button to paste the highlighted text. Most likely in general your issue is from the KDE integrated clipboard manager, configure it and see.

1 Like

Guys, thanks all for your replies.
I’m using Linux for a year now (Windows user before for a long time), and I never realized that this is default behavior (except in Konsole).

I have now found a setting in Plasma to disable it, and that’s what I want:

Gives me exactly the behavior that I was looking for.

Thanks again!

2 Likes

Glad you 've found it, I’d suggest you experiment a bit more though with selection-copy and mouse middle clicking (= paste), makes things much faster than Windows :slight_smile:

Thank you, I appreciate it!
For the moment I was looking how to disable it, but I think you’re right. I’ll try that in the future.
There are many things the way they are made in Linux make it faster. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.