Problem with Breath Splash Screen after upgrade to 6

After upgrading to plasma 6, everything is working fine, except the breath splash screen. I tried to reinstall the packages and check for any graphic driver issue, but found nothing.

extra/plasma6-themes-breath-migration 24.0.0-3 (17.1 KiB 30.1 KiB) (Installed)
    Breath theme migration routine for kconf_update
extra/plasma6-themes-breath 24.0.0-3 (65.5 MiB 65.9 MiB) (Installed)
    Breath theme for Plasma 6
extra/sddm-breath-theme 24.0.0-3 (154.5 KiB 172.5 KiB) (Installed)
    Breath theme for SDDM

$ inxi -G                                                                                                                                                                                                       ─╯
  Device-1: AMD Cape Verde XT [Radeon HD 7770/8760 / R7 250X] driver: radeon
    v: kernel
  Device-2: Logitech Logi Webcam C920e driver: snd-usb-audio,uvcvideo
    type: USB
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: radeon unloaded: modesetting
    dri: radeonsi gpu: radeon resolution: 1920x1080
  API: EGL v: 1.5 drivers: kms_swrast,radeonsi,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.5 vendor: amd mesa v: 24.0.6-manjaro1.1 renderer: VERDE
    (radeonsi LLVM 17.0.6 DRM 2.50 6.9.0-1-MANJARO)
  API: Vulkan Message: No Vulkan data available.
$ mhwd -li 

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI
           video-linux            2024.05.06                true            PCI

Warning: No installed USB configs!

It’s a known issue with AMD graphics on Wayland — it’s a bug in qt 6.7… We recommend switching to X11 for the time being.

Or, you could just disable the splash screen. It doesn’t actually serve any purpose, and it needlessly delays your desktop coming to life after logging in. :man_shrugging:

Not a big issue, I can wait to see if it gets fixed on next updates.

Yeah, I know, it’s working fine in other splash screens too. I just wanted to report because I did not know it’s a known issue.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Actually a bug in Breath splash.