Problem with Ardour plugin GUIs after reinstall

I reinstalled from the Gnome version to KDE. Now non-bundled plugin GUIs no longer work in Ardour. I get an error message “failed to instantiate LV2 GUI”. I did keep my home partition… in case that helps.

When I run Ardour from the command line I get another error message.
“sending key ‘state’ to UI failed, out of space”
It posts over and over again.

The GUIs work perfectly externally; they just won’t work in Ardour. I’m having a lot of trouble figuring this one out. Any ideas?

suil 0.10.16-1 breaks LV2 plugin GUIs in Ardour, you can see the original Arch bug report here:

I found suil 0.10.16-2 has a different issue where plugins can only open once in Ardour, best solution is to downgrade back to suil 0.10.12-1.

sudo pacman -U

And…Welcome to the Manjaro forum. :slight_smile: Never fun when your first post is trying to solve an issue. Hope this was helpful.

Always beneficial to check out the latest Stable announcement thread, there is a wiki post that follows where everyone can contribute solutions to issues recently updated packages cause.

I’m sorry, that’s no idea for ardour, but did you know reaper? You could test if your plugins work there.

But you also said, that you kept your /home partition. Could it be, that there went something wrong, and do you have the option to delete (first backup) your ardour config folder/files from your home partition and then reinstall?

It worked. :slightly_smiling_face:
All the GUIs working just fine with 0.10.12-2. Thanks a bunch.

1 Like